webCoRE Optional Update v0.3.111.20210130


Hi, somehow I started getting “There is a problem loading the dashboard data. The data shown below may be outdated” when I tried to open the dashboard, in ST app, or on a web browser. I tried logging out and logging back in and it didn’t help. I upgraded to this version in Github and the same problem persists. Just to be clear, this started BEFORE the update to version [v0.3.111.20210130]

I tried to access the Security menu in Settings. Could get past the first window (how often the dashboard expires, and password), and then it’s a blank window, and then a message “We’re having trouble connecting. Check your network connections and try again.” My home network is up for sure.

Also, my pistons seem to be working still as I’m getting notifications from them.


Is it possible that the webCoRE Piston smart app did not get published? I am not sure whether the different versions could cause issues.


I believe this is the default error message in the ST app, misleading since it is unrelated to your network. Are there any errors shown at account.smartthings.com > Live Logging?


Here are the messages there for my webcore instance when I tried to access the dashboard from within the smartapp. First one showed after displaying a window for password. After entering the password I got the next one (on top).

(https://graph-na04-useast2.api.smartthings.com/ide/logs#e0c3a459-79ee-448b-9fcf-9f01263bf960) 1:13:05 PM: error physicalgraph.exception.StateCharacterLimitExceededException: State cannot be greater than 100000.0 characters
(https://graph-na04-useast2.api.smartthings.com/ide/logs#e0c3a459-79ee-448b-9fcf-9f01263bf960) 1:13:05 PM: error Dashboard: Authentication failed due to an invalid token

](https://graph-na04-useast2.api.smartthings.com/ide/logs#e0c3a459-79ee-448b-9fcf-9f01263bf960) 1:12:52 PM: error Dashboard: Authentication failed due to an invalid token


Issues with the spinning circle forever on the dashboard. Tried to clear the token, doesn’t seem to help.

1:52:34 PM: error Dashboard: Authentication failed due to an invalid token
is the message in the log.

1:56:49 PM: debug Generated list of null-237 of 237 devices in 16311ms. Data size is 478


I’ve been experimenting with the webCoRE mobile app for GPS so I already have it loaded on my phone. It is showing the new UI. Loading the dashboard in my mobile browser also shows the new UI. It’s just the instance of webCoRE inside of the SmartThings app that is screwed up and I can’t seem to get it to load the new UI. I’ve logged out and back in, it still doesn’t change.

If I remove webCoRE from my smartapps inside SmartThings, will I lose my pistons?



Yes, don’t delete the webCoRE app.


This is a fairly common and fixable error, I will PM you to debug further.


This is kind of a strange combination of log messages, hmm… Normally if the dashboard cannot communicate with the smart apps due to an invalid token there would be nothing else to log. Do you still get that token failure message each time you load the dashboard?

Are there any errors logged by the dashboard in the browser console?

Has anyone with a large number of devices (let’s say 100+) had a successful upgrade? I don’t have enough devices to test this out but will try splitting my devices into multiple responses to make sure that still works properly…


All four smartapps are published as i can see.
At first update try to 0.3.111 i briefly saw something about a database was updated succesfully after logging in to dashboard. Could it be that database is not reverted back correctly after my roll back to 0.3.110 ?


I got a suggestion from the SmartThings forum. Force stopping the SmartThings app and then launching it again fixed the problem.

Update Feb 9/2021: Force stop alone didn’t work the next time I needed to do this. Did a force stop and a clear cache and then it updated. But just clear cache, don’t clear data, or you will have to reorganize all your rooms, devices, and scenes.


I was mistaken about the “Authentication failed due to an invalid token” error. This is not related to the access token provided by SmartThings. Instead, it is a token that webCoRE generates to track dashboard sign ins.

Would someone please try the following to confirm? ST App > webCoRE > Settings > Security > Choose how often the dashboard login expires > Never (not recommended). I am wondering if the “Choose how often the dashboard login expires” feature never worked before and now does in this release…

As documented on screen, this is not a recommended setting but if it works for now that will help to figure out why this is causing trouble. Meanwhile I am going to test out this setting with a very short timeout like 2 minutes to see if I can see what you’re all experiencing.


Now I noticed in my piston logs that sending to Pushover is failing. I didn’t change anything there.

Here’s the error message:

Error executing external web request: com.amazonaws.services.cloudfront.model.InvalidArgumentException: Body parameter should be a string or if json a Map or List to auto convert (Service: null; Status Code: 0; Error Code: null; Request ID: null)

Is this related to the new webCoRE update?


Yes I believe this is probably related tp HTTP request changes, would you please start a new topic for that in the bug reports section?


This seems to work as designed, the dashboard password is required when the token expires, and the correct dashboard password generates a new token. Nothing changed there in this release.

I see that there is always one “Dashboard: Authentication failed due to an invalid token” error logged when signing in to a new browser from a request that fires off before you have signed in. I will see if that can be eliminated but it should not be causing any problems other than this wild goose chase. After entering the correct password ST Live Logging shows “Dashboard: Generating new security token after a successful PIN authentication” and the devices should begin to load.




It’s been so long I almost forgot how to update :wink:
Great work! The update went smoothly for me!


Thank you. Fixed as advised.


Error from console:

1. |Resource|Status|Directive|Source Location|
| — | — | — | — |

webCoRE.min.js:127 TypeError: Cannot read property ‘id’ of null
_ at webCoRE.min.js:898_
_ at webCoRE.min.js:139_
_ at m.$digest (webCoRE.min.js:150)_
_ at m.$apply (webCoRE.min.js:153)_
_ at l (webCoRE.min.js:106)_
_ at webCoRE.min.js:111_
_ at HTMLScriptElement.m (webCoRE.min.js:110) “Possibly unhandled rejection: {}”_

I just rolled back to a prior version and it is loading again. I guess I’ll skip this update :slight_smile: also managed to grab a backup of my pistons - phew.


Thanks @ipaterson for maintaining the project! It was a breeze contributing to the project with your help and tutorials!

When you get a chance, can you rebase staging against these new updates? Otherwise the https://staging.webcore.co view keeps showing:

A newer UI version (v0.3.112.20210202) is available, please hard reload this web page to get the newest version.