Webcore Update Issues



Anyone else having this issue. When I updated Webcore I keep getting this WARNING: Results may be unreliable because the parent app’s version(v0.3.111.20210130_HE) is newer than the child app’s version(v0.3.110.20200210_HE). Please consider updating both apps to the same version. When I under Apps code it has the current version. What am I missing?
I used Hubitat Package Manager to update it. How do I roll back an update? Any help appreciated.

Then when I look


have you tried running Repair in Hubitat Package Manager and selecting webcore?


Yes I’ve tried that and I still get the error message


go into webcore and hit done

HE console -> apps -> webcore


No it still shows the error message as before. The pistons appear to be firing correctly. I was just wondering if anyone else was having this issue.


I would reboot your HE system, and then check the source files again


You should also check that you don’t have multiple copies/files installed

HE console -> Apps Code

  • show everything that is webcore related


I don’t feel this is common but someone on the ST side had a similar observation. A few but not all pistons still showed the old version number. They were able to resolve it by editing and re-saving the pistons. I don’t know what would cause that and assumed it was an ST glitch. Worth a try if all the smart apps are up to date to see if it’s at least a similar type of problem.


On both ST and webcore, there is caching going on. That said, at least on HE, rebooting for sure clears all the caches.

I have not experienced the issue described on HE before, it will be interesting to see the results after a check of the sources, and reboot.


Thanks for the help going through all the steps to troubleshoot the issue. Showing the (2) instances Child and parent apps all looks normal there


Ok I tried the following with no success. Thinking about starting from scratch and doing an uninstall/reinstall. The bad part is I can’t even back up the pistons getting an error message

  • Rebooted HE hub

  • Did an HPM repair(already had done so yesterday)

  • Tried to edit them as ipaterson suggest( not sure if I did that correctly though)

  • Hit done


when you say edit can you explain a bit more about that? edit the entire file or part of it.
Did you see this on this forum or on ST?


I meant just opening an individual piston in the dashboard, clicking Edit, then clicking Save. I am not at all confident that this will accomplish anything, just trying out an anecdote that someone shared.


I have been having the same issue. The only way that I can get it to work, for a little while, is to log off of WebCore, clear all history, cache… and start over. Would you happen to be using a MAC because it is getting to the point that it is really annoying. I would have the same issue with Chrome on the ST version but now I have the issue with all browsers …Safari, Firefox, and Chrome.



This topic is about a warning that appears in the piston log, what specifically is not working until you clear cache and start over?


Yea but it happens like after every 3rd piston I work on. Does it do the same thing on a PC


I assume you are using dashboard.webcore.co

Have you tried with staging.webcore.co?

I have not seen what you describe.

If on Safari on a Mac did you go to Develop -> empty caches ?


I will try the other link. I am telling you I spend more time cleaning out cache and history than I do actually programming. I am using three browsers. When one gives me the error I move to the next browser. I use Firefox, Chrome and Safari. It is just so frustrating


This is getting crazy I did try staging.dashboard and getting the same issue. I am beginning to wonder since this is a work computer that the cause is some IT crap that is on here. There is no one else having this problem


You should open the developer console in your browser or javascript console and see if you see something there.

This does sound strange…