Webhooks issue -- Webhook works, but Webcore isn't sending it


1) Give a description of the problem
IFTTT Maker Webhooks setup in WebCore, but WebCore is not issuing the Webhooks when triggered – there is an illegal character which I am not observing in syntax / URL

2) What is the expected behaviour?
Expect Webcore to issue IFTTT Maker Webhooks with event name

3) What is happening/not happening?
Receiving a log error message: "Error executing virtual command [].iftttMaker: (11ms) java.net.URISyntaxException: Illegal character in path at index 77: https://maker.ifttt.com/trigger/Fan_speed_1/with/key/maker.ifttt.com/ "

4) Post a Green Snapshot of the pistonimage

5) Attach logs after turning logging level to Full
8/13/2019, 8:49:00 PM +326ms
+1ms ╔Received event [My home].test = 1565747340326 with a delay of 0ms
+87ms ║RunTime Analysis CS > 19ms > PS > 56ms > PE > 11ms > CE
+93ms ║Runtime (37737 bytes) successfully initialized in 56ms (v0.3.10e.20190628) (90ms)
+97ms ║╔Execution stage started
+108ms ║║Comparison (enum) on is (string) on = true (2ms)
+110ms ║║Condition #2 evaluated true (7ms)
+111ms ║║Condition group #1 evaluated true (state did not change) (10ms)
+113ms ║║Cancelling statement #3’s schedules…
+132ms ║║Error executing virtual command [].iftttMaker: (11ms) java.net.URISyntaxException: Illegal character in path at index 77: https://maker.ifttt.com/trigger/Fan_speed_1/with/key/maker.ifttt.com/trigger/{event}/with/key/**anonymous
+143ms ║╚Execution stage complete. (46ms)
+145ms ╚Event processed successfully (144ms)Preformatted text


Check the ifttt key you entered in the settings, it might have invisible invalid characters (trailing?).


Thank you – I appreciate your response. Does not seem to be an invisible invalid character. I re-typed by hand and validated the web hook worked properly by copying / pasting into my browser.

In the log above, the error was at index 77, which I assume to be the 77th character in that string. The 77th character is “/”.

Do your have IFTT Maker Webhooks URL look like this in WebCore integrations?



I’m on mobile right now but mine looks like…



Thank you – Mine looks just like yours – so strange. I went ahead and changed my Webhooks key. Not surprisingly, that didn’t resolve the issue.

This is what I have in Webcore – easy copy / paste job from IFTTT

Any other thoughts on what I might do?


Remove the /trigger/{event}/with/key and format it like I have above, substitute your secret key to mysecretkey.

Here’s a partial of my integration setting…


Got it. This is progressing! I updated my integration setting to follow the syntax you advised:

Now I am getting a different error message:

+232ms ║║Error executing virtual command [].iftttMaker: (73ms) groovyx.net.http.HttpResponseException: Not Found

Are you familiar with this error?


From your screenshot, I see you still have /trigger/ in there.


I am embarrassed. Thank you for your patience with me – I wrote that e-mail at 4 am, and clearly not fully awake – You solved my problem – sincere thanks to you!