Best way to ensure Webcore presence sensor and Smartthings mobile sensor work correctly on Android 8.0?


I recently updated my phone (Huawei Mate 9 Pro) to Android 8.0 Oreo and since then both the Webcore presence sensor and the Smartthings mobile sensor only update when I open the respective apps. I’ve seen there were issues with the Webcore presence sensor on Oreo but wasn’t sure if it was resolved or if there was a workaround. I haven’t seen anything about the Smartthings mobile presence not working with 8.0.

Any help would be greatly appreciated as most of my pistons are based off is someone is present it not. Thanks a lot!


I am having the same issue, and I have been unable to resolve it. It appears Oreo places the apps in a state which stops them from polling often enough to get a decent reaction time, it will eventually update without opening the app but it takes a fair while at least in the SmartThings app. I couldn’t get the WebCoRE app to work as a presence sensor on the phone at all! Samsung Galaxy S8.


I’m running Oreo (8.0) on a Galaxy S9 and only using the ST presence sensor. I haven’t had any issues with it. It may be a slight bit slower than it was on an earlier version of Android on another phone, but not a lot. I certainly do not have to open the app to get the presence updated.


Bummer, thank you both for your replies. I had found some extra settings to turn off all battery optimizations and data usage restrictions but after a day, it seems like it didn’t really help. Hopefully something gets fixed one way or another because most of my pistons are reliant on me being home.


I have been having the same unreliability issue with S8 and Oreo. I don’t mind the delay when leaving but I rely on the presence detection when arriving home. I’ve adjusted battery/background optimization stuff but still go no.


I have seen ideas around using Tasker, but I use that for other things and haven’t found it to be much better when it comes to location.

I think Oreo does some RAM optimisation which is what causes the problem and thee appears to be no way to disable it.


I use Tasker and sharptools for a few automations (none presence sensing) and it is already somewhat unreliable.

Over the last few days since the update, I’ve had says where both the ST sensor and Webcore sensor updated right away, and days where neither updated for a while.


It’s a shame there is no function to make you present from a router, I guess if you fixed IPs or set Alias’ for device you could use a Pi to monitor the network for a connection from the device instead?

Also, I see some apps are making use of a persistent notification to try to keep themselves in the foreground. Is there a way to create on via the SmartThings app which might help?


Can I write pistons that execute when I arrive at work? If so, how do I code that?