Device Status Tiles

power
device_health
temperature
tiles
light

#25

Delete the wait that’s there to see if that helps. I forgot to remove that wait on the posted example on this post.


#26

I will test it when im home :wink: Thanks


#27

Yep that fixed it! Still wondering about the error though…


#28

Me too, could be the way the piston is written, not really sure. I posted something about that error a while back here but never got a response.

I also updated the Light Bulb and Light Switch Status Pistons on my original post to delete the wait. If anyone is already using these, delete the 4 second wait that’s on there as I meant to delete this before I posted this initially. With the wait on there, these tiles may not work reliability if you are turning on multiple bulbs/switches at same time.


#29

I updated the Doorbell tile piston above:

It’s working now 100% but it’ll depend if your doorbell button status shows ready for button status like mine does that is a Ring doorbell after the button is pressed to reset the status. If your doorbell doesn’t go from pushed to ready status like Ring does, you may need to modify this piston to the correct status or just put a wait and rerun all the set variables and the set piston tile


#30

What doorbell do you use? I don’t have one yet but i’m looking for a cheap one to buy


#31

Ring Pro


#32

I’m working on more updates to add 24h time and DD/MM date format as a variable. I’m also looking to fix it so the tiles will show even if there’s no events for that device yet such as when the tiles are first added.

Hoping to get that done over next 2 days after further testing.


#33

I’m still having issues with the light tiles. It shows a light is on but it isn’t, i already removed the wait.


#34

Hello awesome community!

I am missing something fundamental that I am not finding posted anywhere. How do you use these tile pistons? IE, I restored one of them - the open/closed contact ‘door’ sensor. I made the changes to map in my door contacts.

Here is the question though. Where/how do I then see these tiles. I see @bfara83’s post #10 above, and see he has a status tiles entry on his home screen. What turns that on? I simply see my new piston as the single row - text based.

Feels like I am missing some 101 step. Any help please?


#35

Click on Options: Settings: Categories. By default, there is one Uncatagorized Category set to Details. Create a new category and set it up with any size tiles setting. Then move any pistons you have set up for tiles into that category. Find an example tile piston to use if needed.


#36

Ok, makes sense…but I still only end up with text lines.

Interestingly, if I select an option with ‘details’ in the name first such as ‘details/medium tiles’. I get the text (details) line at least. If I select an option with tiles in the name first such as ‘medium tiles/details’ all I get is the header row of the category with (count), as if the selection is collapsed, but no tiles and nothing to open.

Just in case tried on updated non-beta chrome and updated non-beta opera browsers.


#37

An open/close would need to occur on the sensor before the tile appears. You also need disable automatic piston state in the settings of the piston.

Yes, if you choose details/tiles or tiles/details, you get the name of the piston showing too.

If your tile still does not show, attach an image of the piston for everyone to view and see what you are doing, click the green camera below the piston and download.


#38

Thanks, I really appreciate it. The kicker might be your adding the knowledge “An open/close would need…”.

  1. I have no power @ home today. :slight_smile: Will try again once the power company restores power.

  2. Used the 8w8se piston in this thread above.

Thanks again. We’ll see later once I have power again.


#39

I’ll post the updated versions of the tiles tonight, let me know if they work better after I post them. The new version will now display the tiles even with if there’s no events.


#40

Thanks! Let me know when they are up :wink:


#41

All the device status tile pistons are updated on the first 4 posts, here’s the changelog:

  • Added comments to the variable section as additional guidance when setting up the variables and piston.
  • Added 24Hour Variable if you want 24 hour timestamps.
  • Added DDMMDateFormat Variable if you want DD/MM Date format since I know it’s formatted that way for some countries. This can be mixed and matched with the 24hour variable too.
  • Added a 10 minute update on-top of the updates when there’s events. This will help sync the tiles if the tiles are not in the correct status and will make the tiles display if there’s no events yet for a device. If there’s no events for a device, it’ll display in the footer as "No Event Yet’ since there’s not a timestamp yet. This will make it so you are not having to manually trigger events for the devices you are monitoring just to get the tile to display. The 10 minute timer can be adjusted if you are having issues with tiles not updating correctly, do not have it update any faster than 1 minute though, otherwise you will have speed issues if you have a lot of pistons.
  • Removed the wait that was added in error on all the tiles I posted
  • Added the clear tile function based on bangali’s presence sensor to remove any extra tiles if you remove a device for example or change devices. This will eliminate extra tiles that are still displaying if you change what devices are assigned to the piston.
  • Fixed the background colors on the Light Sensor tiles since Yellow is hard to read if tile was 10000 Lux level for example.

I highly recommend creating a second instance of WebCoRE for the tiles like I did since it’ll split the memory usage and make everything run and work faster. The WebCoRE site will start to get slow too unless you do this and you can link them together by registering another instance on the WebCore Dashboard:

image

More tiles to come, looking to add humidity, presence and room tiles. The room tiles I want to create is for the Rooms Occupancy DTH located here created by bangali:

https://community.webcore.co/t/rooms-occupancy-dth-with-states-for-rooms-to-use-in-wc-st/1813:


#42

Great stuff! I’ve added them and they are looking good. Also made a new instance for WebCoRE. Can’t wait for the room tiles :wink: I’m using the room occupancy aswell now


#43

I updated the Light Sensor Status Tile above to fix an issue with the timestamps not working.


#44

Thanks for these. However, I’m getting errors, with both the old and updated Light tile script.

Cancelling statement #206’s schedules…
+13862ms ║║Calculating (decimal) 0.0 - (decimal) 1.0 >> (decimal) -1.0
+13997ms ║║An error occurred while executing the event: java.lang.NullPointerException: Cannot invoke method hasCommand() on null object
+14001ms ║╚Execution stage complete. (474ms)

I put the context so you may be able to determine which line it is.
It’s the same error as @johhnwilliam above.

It keeps on turning on my light (the first one in the list - ie: device1). Happens every 10 mins or so.