External URL - All links are broken


Normally, when I copy an External URL from a piston, it looks something like this:


I noticed today that each piston I’ve looked at, now uses a totally different server, different URL (undefinedexecute), and the links no longer work…


Has anyone else noticed this?

Are all of my External URL calls doomed to fail for the next six months while SmartThings gets their API up and running?

Execute piston via external URL - not working at all

Further testing shows that some old links still work, but new pistons do not show the correct web address. And so far, no amount of rewriting the URL has been successful…

IE: When I force the beginning of the old URL and the ending of the new URL it fails…



Are you using any version of this patch?


Nope. No patches here.


Just attempted to duplicate including building a new piston and not seeing any issues. Your web url looks problematic and should be in the form of:


Did/Can you attempt to clear your browser cache or come in as Incognito and see if this resolves?

(I am running the patch)


That is the path in the address bar when viewing/editing a piston…
There should be a different path for the External URL call…

Cache has been cleared… Multiple browsers checked



Where is that ^^ screen capture done? with “undefinedexecute” shown? Not familar.


That is PC Firefox… window resized, hovering over this link:

Multiple pistons and accounts checked in Chrome as well…



I run a Mac but have W10 running in a virtual machine. Just tried Firefox 70.0 (64-bit) with success with existing piston, copied piston and new piston. Running v0.3.110.20191009 with the patch mentioned that really should have no understanding of the external url presented. It forms it own using the same logic the web ui uses.


I think I found the problem here. I can’t get it to happen for me but I think I see where it may have happened.

@WCmore, before I make any changes would you please sign in at staging.webcore.co to see if you have the same behavior there? It is currently identical to the live dashboard.webcore.co, so the plan is to reproduce this problem there, then test a code update which might resolve the problem.

I’m not sure if it will be reproducible this way though if the problem is what I suspect, no need to keep trying until it breaks, just let me know what you find.


Staging gives me the same results:



Excellent, would you please sign out of staging.webcore.co, refresh your browser to load new code, then sign back in? Let’s see if this fix helps.


The links look correct now… A single piston URL was tested, and executed properly.
(I did not even have to log out or clear cache to see the improvements)

Thanks for this, Ian!


Thanks, if you wouldn’t mind giving it a few more sign out/in rounds to confirm I’ll push this out tomorrow.


I have logged out twice from the Dashboard… cleard cache twice… and both times tested two random pistons… The External URL (in staging) looks to be the right format now.


(I have tested one of those URLs sent from an external app, and it worked perfectly)

Is that enough information to be helpful?


Indeed, thanks! I pushed it out to dashboard.webcore.co.


Thanks a lot Ian!

The dashboard is now displaying the correct External URLs… :+1:


Hello friends, mine is still broken. I have logged in and out twice.
New blank piston I made has the following URL:

All my pistons URLs have that format now. Everything is broken.

Thank you!!!


Please try a hard refresh on the dashboard to ensure the latest dashboard code is loaded.


Bingo! That worked, thank you so very much, you rock!