Gauge tiles not showing correctly


The only person who has mentioned working gauges recently is @guxdude over here

Not sure if they are still working for him though…


Mine are still working. I had a brief problem when I tried to display them on a second tab and they didn’t seem to work but once I closed the second tab, it worked again.


Still not working here, apparently the google script was blocked?

From google chrome console…
Refused to load the script '' because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-inline' 'unsafe-eval' * * * *". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.

Edit: I temporarily disabled CSP for the dashboard site and all gauges are back.


Just did the same and they are all back now!

My standard square tiles though are still seemingly out of sync with old data showing even after all of the attempts and refreshes as listed above.


Brilliant… I was just about frustrated enough to start my own digging… Thanks for getting me started…

I installed a CSP sniffer on my browser, and refreshed my Dashboard to study the data pulled…

It appears that the CSP is allowing:
but Google is now serving those from:

Changing the ‘csi’ to ‘www’ (or * if you are adventurous) will allow the gauges to be drawn.

If it helps, here is my pic which successfully allows the Google gauges.

default-src 'none'; connect-src 'self' *; frame-src; img-src 'self' data:; script-src 'self' 'unsafe-inline' * *; style-src 'self' 'unsafe-inline'

Note: I had to place in both script-src and style-src for it to work…
(also there’s two references to fontawesome, so the Dashboard images would load fully)

I am pretty sure that these settings are configured on webCoRE’s side, so hopefully it’s easy to update.

Tagging @ipaterson


I don’t have any gauges to test this out, is it fixed now?


Negative, still have to do the CSP hack for them to show. Did a hard refresh as well to verify


Unfortunately, no. When I refresh my page (using no plugins), the gauges are solid color. (not working)

Was there something in my example above that was not listed in webCoRE’s custom config?

(when I was condensing the fairly long list, I noticed the gauges stopped drawing when a few other Google links were left out)

It’s tricky though, because that first command:
default-src 'none'
means that anything not specifically listed, will not function

For testing or fun, here is a great piston that draws a gauge every 10 minutes…
(for others who find this later, just save it to a category that displays Tiles)


I pasted in an example and this is what shows up for me:

As far as I understand the problem this image wasn’t showing up before? Are we all on


That’s more than I see…


(all 20 gauges spread across 3 instances… It only draws the background color)

My dashboard is that same link, but it is https


I think we’re good here. The page is cached by CloudFlare so I still occasionally get the CSP blocks but occasionally get the gauges on refresh. This should clear up over the next few hours while CloudFlare ages out. If still a problem tomorrow let me know and I’ll see if I can manually invalidate CloudFlare.


Perfect… If anything, I have mastered the art of patience, LOL

Thanks for your help!!


I can report that my home machine has now started showing all the gauges again so appears that it has been fixed! Thanks again!


Looking good on my side too…


Thanks again!


While we’re somewhat on the topic :slight_smile: tell me more about your last 2x gauges there. The first one is what I do for a living and the second one I usually do on the weekends!


They “Concert” countdown is based on this thread.
(I recommend importing the piston from the 2nd post)

The “Car Wash” countup functions very differently…
(I have not posted that online yet)