Github integration brick wall


1) Give a description of the problem
In following step by step webcore install instructions, Cannot progress past "Authorize Smartthings

2) What is the expected behaviour?
The ability to click on green button “Authorize SmarThingsCommunity” to progress to next step.
3) What is happening/not happening?
The screen stays on “authorizing will redirect to
4) Post a Green Snapshot of the pistonimage

5) Attach logs after turning logging level to Full


What browser? Have you tried using a different one to see if that has any effect?


it wont even pop up with IE, I am using Google Chrome.


I’ll give it a shot in fire fox now


same issue


You can do the manual install in the interim until someone is able to help you figure out the GitHub integration


Manual install was followed however i cannot manage to install the mobile app. Webcore does not appear in “My Apps” under Marketplace in ST Classic


Are you logging into IDE at ?


yes through samsung account


I did see a few days ago where someone was installing a smartapp in IDE and it took 45 minutes to show up in his My Apps section. :frowning:


I’ll give it a while. Its been an hour since the manual install. I read another issue you replied to a year ago…

2 yes
3. i dont know the answer to this nor how to tell
4. yes
5. yes
His resolution was some sort of password change though I’m not sure i understand.


There could be an issue with IDE. Seeing how you can not integrate your github account. Nothing showing on the ST status page at the moment.

You can contact ST support at to inquire about that.


Did you do the oauth part.


My bad. I see you did.


I made sure my ST account and WebCoRE account matches (saw some threads where that was the issue) they do. I logged out and back into ST classic and redid the manual install of the 4 apps in webCoRE, webCoRE, pistons, storage and dashboard. WebCoRE STILL will not appear in SmartThings Classic> Marketplace> Smart Apps> My Apps.

Any help is greatly appreciated.


not sure what you mean by webcore account. if you are referring to this forum then that has no bearing


  1. you are logging into the ST classic app by choosing New User and logging in with your Samsung account?
  2. you are logging into IDE using that same Samsung account?
  3. check in IDE to make sure you only have one Location listed under My Locations

  1. Apologies, i misspoke, by webcore i mean to say IDE.
  2. I did ensure my ST classic account and IDE account were the same.
    3)The below screen shot shows 1 location


You should probably contact ST support and see if they can identify any issues that you might be experiencing. Unless a webcore minion wants to step in and offer you any assistance. I am at a loss for what is going on.


I was told to disable browser extensions and clear cache not sure which worked but after that I was able to integrate Github and that install method led to success. I wish I knew what I did wrong in the manual install to help anyone who may read this in the future. Thanks for all the help!