Honeywell Total Connect Thermostat disappeared


1) Give a description of the problem
My Honeywell Total connect Thermostat has disappeared as an available device in WebCore. The device is showing in Smartthings. I added the device in WebCore; under\Available Devices\Capability Group3\Which thermostats (cooling) or (Heating)\Honeywell Thermpstat

2) What is the expected behaviour?
The thermostat should be selectable under \Physical Devices

3) What is happening/not happening?
All references to the Thermostat in existing Pistons, is now showing as a serial number, and the Thermostat is not available to chose for update in the Piston

**4) Post a Green Snapshot of the piston![image|45x37]

5) Attach logs after turning logging level to Full

WebCore is showing twice in SmarThings automations

My Honeywell Redlink keeps losing internet connection. Honeywell problem?


I found my thermostat under \Capability group 2\Which refreshable devices and now I can select it in Webcore. However, this doesn’t seem like the right fix, because I should be able to select my thermostat under \Capability group 3\Which thermostats. I can enable \Capability group 3\ Which thermostats (cooling) or (heating) but that action does not enable it in WebCore. I suspect this issue is also related to device type selection for the device in Smartthings. Is there any documentation that explains the different device type options?


Resume Program option is not available…I use “Resume Program” in a presence sensing Piston to resume to the thermostat heat setting from a temporary heat setting when I return.

I am still not able to select my Honeywell 9000 thermostat under “Which thermostats”. I can select it under “Which thermostats (cooling)”, and “Which thermostats (heating)”. I suspect recent changes to the Webcore backend have resulted in this functionality disappearing.


The ‘thermostat’ capability has been deprecated for years now, so long ago that even webCoRE supports the capabilities that replaced it. Only legacy integrations would support thermostat.

There has never been a ‘Resume Program’ commamd in any capability, just custom commamds in certain handlers. The current SmartThings ecosystem doesn’t support custom commands.


Bummer…I setup a few pistons using “Resume Program” in 2018, and they worked until about the end of Sept 2021. Thanks for confirming.


Out of curiosity (I don’t have a smart thermostat), do you have the option of setting the thermostat mode to ‘resume’? If so, what does that actually do?