How do I update webCoRE SmartApps in the SmartThings IDE?


#1

1) Give a description of the problem
I keep seeing the following message when I logged into webcore.

A newer SmartApp version (v0.3.113.20210203) is available.
Please update and publish all the webCoRE SmartApps in the SmartThings IDE.

2) What is the expected behaviour?
It should be the latest version and this message should not be here.

3) What is happening/not happening?
Keeps saying I need to update but I can’t update. I already followed the instruction on this webcore wiki: https://wiki.webcore.co/#Updating_webCoRE
This is what I see on step 4 of the above wiki.

A newer SmartApp version (v0.3.113.20210203) is available.
Please update and publish all the webCoRE SmartApps in the SmartThings IDE.


#2

If you open each of the 4 webcore smartapps in IDE by clicking on the name… do they display the same version for each. The version should appear near the top.

If they are all the same, try logging out of the webcore dashboard and generate a new registration code to sign back in along with your password.

If they are not the same, you can update the one(s) that are not current.

Also, try a hard refresh of your browser cache.


#3

They all display the same old version when opening up in IDE.

I tried several time by logging out and logging back with new code and it still says I need the new version.

I even tried with a different browser in private/incognito mode and the same thing. There is nothing in the Obsolete and Conflicted boxes. I have also tried disconnect and reconnect to github but nothing’s changed.


#4

I have also followed this thread but it does not work for me either.


#5

Two options to try….

  • Disconnect your GitHub account in IDE, re-authenticate your GitHub account and then see if updates show for you.

  • manually copy/paste the code for each smartapp in IDE…. Save/publish


#6

From another thread, one person says, “I pasted the “raw” code into each of the four SmartApps, saved, and re-published to me.” The question is, how/where do I find the “raw” code so that I can paste into the four SmartApps?


#7

Yeah, I already tried disconnect and reconnect, it didn’t work. Where do I find the raw code?


#8

Look for the links to raw GitHub code


#9

@jkp, thank you so much for the help. That solves the issue I’m having.


#10

Just an FYI… webcore will be phased out when ST shuts down groovy on their platform, you may want to start planning to use Routines and scenes in the ST app.


#11

Wow, good to know. Do you know when is the deadline for ST shutting down groovy on their platform?


#12

They have not set a date but it appears to approaching quickly as Edge drivers are in beta. There is also a Rules API and Automation Studio you should check out. Search the ST forum to get more info.


#13

I know things have moved on, but the screenshot in the original post is showing the SmartThingsPublic (master) repository instead of the webCoRE (master) one so it is unsurprising nothing interesting was to be found.

If webCoRE wasn’t an option for ‘Update from Repo’ it should have been possible to add it via ‘Settings’ with the owner ady624, name webCoRE and branch master.


#14

@orangebucket, very observant! Yes, that solves the issue why I’m unable to update via “Update from Repo”.


#15

Hi guys - Several years ago I created lots of pistons with webCore and things have been running great and I haven’t needed to use it much. However I have a little new webCore things to implement and I realized that it hasn’t been updated in two years. I’m running v0.3.110.20191009.

In the past, to update webCore I would just go to the SmartApps section in the IDE and it would show this:

and the ady624 options would show in purple when an updated was needed. Then I would click Update From Repo, then select “webCore (Master)”, then it would show me 4 things, I would check them all off, click the Publish check box, and click Execute Update and everything would be updated.

However, when I now (years later) try these steps, ady624 lines are all black instead of purple, showing no update available. And if I click update from repo anyway, its all blank.

Can someone please explain what I need to do to update to the latest?

I am, however, concerned that with all the changes between the older version I’m using and the latest version, that some things might not be fully backward compatible, and that I could create a mess by doing this - breaking some of my pistons. How safe is it to upgrade and do I have to worry about that? Worse case scenario, could I (and how) go back to these versions?

Thank you everyone!


#16

You can manually update each smartapp if you choose. I posted the raw links above that you can use to copy/paste the code over the existing nes in IDE and save/publish.

But if everything is working… just leave as is and don’t update. Webcore on the ST platform will most likely be phased out when groovy support ends on the ST platform. The best advice is to start planning to move your current pistons over to Routines in the ST app or Rules API if you plan on staying with ST.


#17

Will webcore continue on habitat once groovy is closed down?


#18

Yes