How to Add SimpliSafe to WebCore


I have been controlling my SimpliSafe alarm with SmartThings Routines for a while now. I recently discovered webCore. However, I cannot see my SimpliSafe Monitor in webCore. How can I add it?

In the SmartThings IDE, I added the SimpliSafe Alarm DTH from the SmartThings Forum ( In My SmartApps, I have the SimpliSafe Alarm app. The SimpliSafe Alarm shows up in both the Classic and New SimpliSafe Apps.

However, it doesn’t show up at all in WebCore. It doesn’t appear in the list of available devices in webCore when I check settings (although all my other devices appear).

Anybody get this to work? Any suggestions?



Did you also look in the section labeled Select devices by capability in group 1-3?


I did, but I thought everything said I couldn’t add anything at this time, but now I see the “Which alarms and sirens” to add and was able to add it. Sometimes the simplest things are overlooked. :grin: That was easy! Thanks!


OK, now I have a related question, although this might not be the forum section to post this in. With the alarm, this is an option for “away(…)” and “off”, but not “home” or “stay”. Is there a way in webCore to manually change the “Do” command? In testing, I just added the away(…) command, and it works, but I’m wondering if I change away(…) to home(…) or say(…) will it work? I can’t figure out how to edit the line (see screenshot below). Thanks.



Edit your piston, then click on Away and change it.

As for the other commands, I don’t have simplesafe so I can’t answer. But if the commands are showing in webcore, they would available through the device handler so they should work. Only one way to find out - by testing them :slight_smile:


When I click on Away, I only get the list of options already available in the list of commands for the device. I was hoping there was some way to edit it directly rather than just picking from a list. If I could change it, I was going to experiment to see if something other than Away worked. The device handler has home & away in it somewhere, but beyond me how to edit it. I’ll keep poking away to see if I can figure out a way. Thanks.