Hubitat Elevation


#67

Does the piston itself work despite the error… some things do throw errors but so far I’ve found they still work… error handler needs some tweaking still.


#68

It does work… I suspected the error came from the ‘Push’ command but I have straightened it out. I just have to wait for the piston to execute again to see.

Thanks for the help.


#69

Is it just a case of copy and pasting the presence sensor code that existed in ST? or is there some modifications i need to do?

I’m assuming github integration doesn’t work yet in hubitat?


#70

Yep… just copy paste.

You just need to change any references to ‘physicalgraph’ to ‘hubitat’.


#71

Is there a quick way of finding these and replacing them? Is there may of them?

Is that the same in all the drivers that you have ported?


#72

In the Hubitat IDE you can press Shift-Ctrl-R and it will guide you through a ‘replace all’.

Yes, every device driver / app you port over needs this tweak… for most of them it’s the only tweak needed.


#73

Is it just me…but i can’t seem to find any reference on the original DTH for ‘physical graph’. Does that mean it’s ok to just copy and paste?


#74

Yes, I couldn’t remember if it was there or not… it is on the smart apps.


#75

Managed to add the presence sensor without issues. Thanks.


#76

Has anybody had any luck getting the external URL to work? I have quite a few pistons listening in on some other apps and am really hoping to get the external URL to work. That will also allow apps like ifttt and zapier to work with the HE version of webcore.


#77

Nope… it was touched on briefly in the Hubitat forum but not working… throws an error every time!


#78

You can fix that by putting at the end of the url ?access_token={access_token}

That will give you a success message and timestamp…however, it still doesn’t fire the piston.


#79

That’s what I’ve been trying but I just get ‘internal server error’ :frowning:

image


#80

Sorry…try with ‘&’ instead of ‘?’ That should work.


#81

I’ll try later but I’m 99% sure it’s meant to be ? Not &, as per other apps using tokens and URL norms.


#82

As there are no other parameters on the URL it should be a “?” but where is the access_token value found so I can test … sorry … brain dead today - and we are out of coffee … MEH!


#83

Go to the installed apps page and click on the ‘i’ Symbol next to webCoRE. You can then scroll down to find the token.


#84

Ok, so I created a piston that had no logic - just
With Light
Turn On

Opened the external link and appended ?access_token=

I did get a positive return from webcore
{“result”:“OK”,“timestamp”:1525450467988}

But yeah - no love and no light (and no log info either)


#85

@RobinWinbourne @kayvint, JohnHoke

Fix for executing pistons externally coming soon (or now if you want to pull down from my repo branch). Other changes are in the conversation tab.

If you are running a local version of webcore, you’ll need to do an update too if you want to be able to click the links without having to manually add the ?access_token=


#86

FYI… price went up. Use promo code LASTCHANCE99 this weekend to still get a Hubitat Elevation for 99…