[Install Instructions] webCoRE Presence Sensor on your Android (beta)


I’m thinking they’re separate processes, otherwise it would shut down the presence part as well. Once it’s set up, can we just have the presence as a separate app?


Since the developer is now officially working with Smartthings, can’t the webCoRE presence be fully integrated? SmartThings is always running anyways.


Pixel2, no luck getting it to work

DTH installed from GitHub
Installed current app from Google Playstore
Created a new device in the IDE, assigned it the WebCore Presence Sensor
Create a Home and Work location in the Dashboard via the browser

Recent activity in the ST app always show, no recent activities, even though I leave everyday and drive 35 miles to work. The only tiles that are populated are Rick’s Phone, Away (weird since i’m home) and sleep

Anything else to try


Did you go back into WebCore and make the sensor?

You then have to go in and make it available to WebCore like any other device. Also note:


Well I created the device in the IDE if that is what you mean. The step in the instructions that talks about the green button doesn’t appear for me “Once you have at least one place added to the list, a green button should appear with the Setup sensor caption. Tap on it and you will get a dialog asking you to provide a name - this is the ST device name for the new presence sensor.”


OK. Deletd my device, cleared cache for the WebCore app. Upon relaunch I re-registered it and signed in. Now when I go to settings I see the green button for the first time. Selected it, named my phone and saved. I now have a new device in the ST app but it’s still showing present even though I’m 40 miles away. Stopped and started everything with no luck



I had it working on my note 8 for a couple weeks perfectly. Then it just stopped. I deleted everything and tried to set it back up again, but now the green button will not come back up. Any ideas?


For me, I had to clear the cache in the WebCore App, then upon a new login, go to settings and it reappeared.

That however is as far as I can get. Just came home and it still is not showing my presence correctly

Good luck


What is not showing your location. Correctly? You said you deleted the device. Did you follow the instructions this time?


Yes, figured out how to get the green button to show to add the sensor using the WebCore app by clearing the cache

Once I log into the ST app, find the device, it show as present (which I am) then when I select the device it shows as away. If I select Recent Activity, it says no recent activity



If the question of following the directions this time was for me, the answer is yes. I had 3 phones working perfect. Then 2 of them stopped. I haven’t messed with the iPhone yet to try and fix the problem. But the note 8 won’t work. I have a pixel XL with no problems.


Took me some time, but the sensor started to work. Not sure what it took so long to jump into action. Though wondering why this sensor can’t be integrated into a smarrthings smartapp? The parent smartthings app already has location granted. 2 Apps on the phone for the same purpose seems like clutter to me.


@ady624 Any chance this is still being worked on?


I sure hope so, mine still isn’t working



I’m still hoping a solution for it being a battery hog can be corrected. I’m on the line about uninstalling it from all three people at home. It’s killing our battery times!


Agreed with the battery I installed yesterday and the phone got really hot, battery got caned. I closed the app re-booted phone and used today OK, Interesting I have three routines One to tell the wife Ive left work, one as a way point to say nearly home and one in the home geofence to open the door and put the kettle on. First time it didn’t work so the next time i had the android app open on the phone and all worked as expected.


Well, dang it. Our phones upgraded to Oreo on Sunday night and the WebCoRE presence sensor now works sporadically when it works at all. Tinkering with the various battery optimization settings seems to make no difference. I guess I’m back to the ST presence sensor with all its limitations. :worried:


Does anyone know how I can join the beta in the play store? It says that it’s full!


You don’t need to be part of the beta to use the presence sensor anymore. The Webcore app is available in the Play Store.


Can you post the link? The only Webcore app today shows for me is a beta.