[Install Instructions] webCoRE Presence Sensor on your iPhone (beta)


#227

Perhaps it’s some kind of permissions thing… maybe try removing the WebCoRE presence app and reinstalling… then be double sure to click both the authorise permission pop-ups correctly (there will be one when first opening the app followed by another generated by the website within). If that fails we’ll need to start digging further.


#228

Open one of the places and then save and try it


#229

Thanks @c1arkbar that worked!


#230

I could not get Webcore presence sensor to work only on my son’s iphone. Is there an ios version requirement? I think he is not on ios 11 yet.

I have installed the IDE and the app on his phone without issues. It initially detects he is away (we were in Canada this weekend) but when we came home his status did not updated as home, while mine and the wife’s had no problems updating.

What else should i loook onto?


#231

It needs iOS 10.3+, bit of the App Store let you install it on your sons phone he must already meet that requirement.

What do you mean by installing the IDE on his phone, the IDE is a website accessed via a browser, it’s not an app that needs installing.

After installing the webCoRE app, did you open the app, authorise it to access location and then go into the webCoRE settings (via the webCoRE app) to setup the presence sensor? Is there a new Presence device with your sons name listed in the ST ‘things’ list?


#232

by IDE i meant ive done this part.

yes.


#233

Then I’m not sure.

Maybe go into iPhone settings and check webCoRE has the correct permissions… maybe you accidentally clicked no…

Settings > privacy > location settings > webCoRE

Should be set to ‘always’


#234

i will re-install and check again.

but just to make sure, after installing the webcore app and i go to settings to setup the new presence sensor, nothing usually happens when i just tap the “presence sensor icon” i have to tap one of my set locations i.e. Home and then it lets me configure the name of the presence sensor. am i doing it right. looks like this is the same steps that i did to setup mine and my wife’s as webcore sensors.


#235

That’s correct… you need to setup a location before it offers you the green ‘setup Presence’ button.


#236

at the moment, when i set up my phone as a presence sensor, i created HOME and WORK locations that are visible on our WEBCORE DASHBOARD.

screenshot of my son’s iphone
image

nothing happens when i tap on SETUP SENSOR… BUT when i TAP the HOME location, it allows me to input a WEBCORE PRESENCE SENSOR DEVICE name which i have done a lot of times.

after which, the presence sensor(my sons) just stays stuck at HOME.


#237

@webCoRE_Minions


#238

Works fine for me.

Have you tried updating WC from git repo?


#239

Its up-to-date


#240

Sorry been following this but I do not have any idea


#241

just re-did the same steps again but for some reason, the ST app discovered it as new presence sensor and i just acknowledged it. i was also at the same time trying to get an ARRIVAL SENSOR connected to the HUB, as it too, was being problematic.

looks like the webcore presence sensor is now functioning properly and hopefully it stays that way…

thank you all for looking into this …


#242

For some reason my daughters presence stopped reported yesterday and shows her present all the time on her iPhone. Is there a way to reset it to start reporting again? Her iPhone presence through Smartthings is working fine.


#243

Try opening the webCoRE app on her phone. Does it open? It might ask for permission to run in the background again.

I’ve seen this before and just opening and closing the app has worked for me.


#244

@RobinWinbourne Robin how do I get this onto my wife’s iPhone?
3d


#245

Just download the webCoRE app and setup the same as yours… it will create a new device ‘thing’ in ST for each mobile device activated.


#246

Yes I did that but I don’t have the code.