[Install Instructions] webCoRE Presence Sensor on your iPhone (beta)


The ‘register a browser’ code comes from the webCoRE smartapp within the ST app (can generated on a different device if required)


Not sure what I did wrong, but I had a piston for me that was working and in the list it showed Present when I was home (TRUE) now both mine and my wife’s show (FALSE) In SmartThings it shows present as it should when home. Look at the list of Pistons Joel Presence and Presence mine at one time showed true when I am home.Any ideas? I have included the Piston for me , my wife’s is the same but her name.


Is the piston itself working?

‘Changes to’ doesn’t stay ‘true’ for very long.


OK when I use the test button for my account I don’t hear anything. But with my wife’s I hear Alayne is away. Both Pistons are the same except the names of the presence sensor.


OK my wife left, the SmartThings app showed away, but the Piston failed to send push or audio.


That might be due to your use of ‘changes to’… I thought it had been fixed a while back but I think you still need to ‘initialise’ the state (i.e. needs to change once to get it primed, and then it works going forward).

state null changes to away - no response, piston primed
state away changes (back to) present - piston fires


Sorry Robin you lost me.


When you first save the piston, the Presence state is logged as null… changing from null to away does not trigger the piston.

So you need to have one state change to set the current state in webCoRE… and then subsequent state changes will been acted

Though I’m sure this was fixed ages ago!! So might not be the problem I’m afraid!


Anyway… as you have no other triggers or conditions, I’d suggest just using IS instead of ‘Changes To’:

If Presence IS away
Speak message
Speak message


I think you might be correct, I thought when my wife came back I heard the sound, but no push.

OK will do that now.


Btw… save waiting for you wife to come and go and just use a simulated Presence Sensor for testing :wink:


Will do. I changed it to is not present and is present. My presence is reporting as it should, so my wife is next.


Ever since I updated the smartthings app yesterday to the latest from the appstore when I select on a presence sensor to see the status it just closes the smartthings app. Anyone else have this issue? It seems to be working, all presence sensors are changing away/home and all webcore scripts are working. Just cant see the status by selecting one through the smartthings app.


Mine is doing the same


Try this


Just tried this by adding the type: “generic”, part and still have same issue. It just closes ST when I try to open up a presence sensor.


Did you re-publish the the DTH and restart the mobile app?


Forgot to publish, but when I try to publish it it gives an error of

startup failed:
script_dth_178aa19b_7b64_4ad3_9405_60d6546ac842_ver_0_2: 80: Invalid variable name. Must start with a letter but was: “generic”
. At [80:55] @ line 80, column 55.
e: “display”, width: 2, type: “generic”,


Mine doing the same thing here, not a full crash as it loads back to things, not dashboard.


Worked for me as well! Thanks!