[Install Instructions] webCoRE Presence Sensor on your iPhone (beta)


After trying again the fix from @JohnHoke you cant just cut and paste. It will enter different quotation marks than what is needed. Once I typed it in all is working again. Thanks @JohnHoke


Great catch!

Apparently the forum’s "s are different … "The More You Know " LOL


I took the liberty of updating your post… you have to paste code snippets into the preformatted text quotations.

This can be done by slelecting the pasted text and then clicking the image button or by using that little known button on your keyboard.


Copy / paste should work now :wink:


@RobinWinbourne thanks a ton!


I’ve been using this presence sensor for nearly a week, and have created a few cool pistons using the extra data available and multiple places. But, I’ve found that simlilar to the iOS Smartthings device presence sensor, its does not always seem to update all the time. Seems to be more common for my wifes iPhone, but i have occasional issues as well.

So just a couple questions as I try to make sure its not user error (probably is)

The app itself does not have to be “open” right? My wife swipes away/closes all her apps.
It seems as if a few times I’ve left my “outside” bubble, but was still close to home and it did not report away. Likewise, once or twice, it took 30 minutes or more to update arrvivingatplace. Showed me at home, but never showed me as arrivingatplace =home.

Just general annoyances. I’ve made my departure bubble bigger (even though I wanted it smaller) and that might have helped, I’m still watching closely.

Mostly just looking for tips on how to make this more stable for me. Again, I love it and it’s pretty stable, but for me in the begining I jumped in 100% and switched a lot of my routines to use this as my main presence sensor, but after 4-5 days, I’ve reverted until I work out the kinks.


Looking for some help on filtering out low GPS updates.

I am still really having an issue with false location updates. Since I can only make the geo-fence 50 meters. The main road I drive near my house is 288 ft (87 M).

I was looking at the DTH for the presence sensor. Is the statement below (and in one other place) where you are filtering out phone GPS events that are under a certain accuracy? It looks like it will take GPS updates with accuracy to 100M (328 ft) in the standard device handler.

What I want to try is to filter out GPS horizontalAccuracy updates.


Maybe this will help.

I went ahead and made a copy of @ady624 DH and changed if the horizontalAccuracy was > 10, then drove around where I have been getting false arrival/departure triggers. Regardless of the change above, the arrivingAt and presence are still being update. I can see the info message I stated above, but things just keep getting updated anyway. Here are the logs I captured:

There are no horizontalAccuracy updates lower than 10 until I am actually at my house.

Can someone please advise?

This is why I need to only take accurate GPS readings into account in the app


webCoRE Presence Sensor - Approaching Places
Arrival/departure if/then or case statement?
webCoRE mobile app - iOS Source Code
WebCoRE Presence quickly changing present/absent/present

Do we still need Test Flight for this?


no. its available at the APP STORE


Can anyone please help on my issue?

I am willing to fully test any changes to help improve this. There are several posts out there where people are having piston issues (including myself). The extra arrivingAt and departingFrom are making the pistons cancel from what I can see. I just want to be able to control only allowing the presence app to update when horizontalAccuracy is better.


I don’t have any help, but I agree that I often get false alerts. What is a good HorizontalAccuracy? Mine seems to be averaging, 150-200ish. Just sitting in one place sits at 16 at the lowest. I cannot find any time it was less than that.


I am not sure what good horizontal accuracy would be. I would assume it varies by device, cellular company etc. What I am looking for is to be able to tailor that accuracy and truly disregard low accuracies based on the need.

i.e. I typically get horizontalAccuracy less than 20 when I am moving slow, stopped or approaching my house. The problem is that the geofence for arrival is being triggered sometimes 300 meters from my house even though my geofence is set at 250m. I have asked of there was a way to make the geofence smaller, but never got an answer on why it is not possible. What I know is that this limitation is causing all kinds of false alerts. The only option I thought I had was to filter out the low accuracies.


My webCoRE presence sensor always says present, no matter how far away I drive from home.
Arriving radius 117m, Leaving radius, 354m. I’ve driven miles from home, no change.

Could there be a setting that I need to change?

Using my iphone as a presence sensor works very well lately.

Also, I see reference to way to check Horizontal Accuracy. Where do I find that?


There is a setting in the device for presence. Make sure it’s set to automatic. You can set it to force present or force away but it should usually be set to automatic


Thanks for the suggestion, but it looks like I already have it set to automatic.


One more odd thing:
In ST app, the things list shows “Present”

But if I click to get more info, it shows me as being Away.

I’m sitting in my living room with my iphone 2 ft away from my router and ST hub.


could just be a ST refresh issue… sometimes if the app is open too long, states don’t update properly on the ‘things’ list… happens to me all the time.

Try force closing the ST app and then re-opening.


Thanks, but I’ve tried that many times, even rebooting the phone. No change.
Any chance I don’t have things installed properly?


Maybe… perhaps start again, delete the simulated device and go into the webcore app to re-create it.


Okay, so I clearly have done something wrong.

I went into the WebCoRE phone app and deleted “The Inn” from places.
Closed/re-opend the app, went to settings and re-created a place called “Cornerstone Inn”.
Saved it.
I can close and reopen the webCoRE phone app and it is there, but it does not show up in the ST app under things.

To back up a bit, this is what I have done to get to this point.

  1. I have the webCoRE Presence Sensor v0.2.102.20180201 device handler installed in the IDE. However the text for that line under My Device Handlers is black, while all the other DH’s are green. Could this indicate a problem?

  2. I have the webCoRE smartapp v0.3.000.20180224 set up in the My SmartApps section of the IDE.

  3. On the ST app, if I go to Automtaion/WebCoRE/settings/available devices, Cornerstone Inn does not show up under any category, including Presence Sensors (but my phone does).

  4. Webcore seems to be working properly, at least I can edit/create pistons on both my phone and PC and they run.

What do I try next?

Thanks in advance for any assistance