[Install Instructions] webCoRE Presence Sensor on your iPhone (beta)


Locations don’t show up as things in ST… only presence sensors do.

I suspect you originally created a presence sensor called ‘the inn’, instead of a location… I’m not sure what locations you built but as you thought you had already setup ‘the inn’ location, you probably don’t have a location set for ‘the inn’ and therefore coming and going from ‘the inn’ would do nothing.

I should have realised this when I saw your presence sensor had a location centric name, instead of a person name.

the app wont let you install a new presence sensor until you delete the old one. At which point a green button appears in the webCoRE location settings instead of the ‘+’ button.


You appear to be right.
I think did use the Setup Sensor button the first time I tried this before setting up a location.
Wasn’t paying attention to the instructions, I guess.

I deleted the Cornerstone Inn item.
I created a new Location.
Now when I try to add a sensor don’t see the Setup Sensor button.

You suggest that I have to delete the old presence sensor first, but I don’t see any existing sensors.

Where do I go from here?


Delete it from the ST app




I don’t see any presence sensors listed in the ST app.
The original one is gone.


ok… then creating a new location in the webCoRE mobile app should make the ‘add presence sensor’ green button appear… If not, force close the mobile app and re-open.


When i go to settings in the webcore mobile app, the green button appears for a split second and disappears before I can click on it. Then it becomes the + button.


That’s normal… just create a new location and then the green button should stay in view.


Can we please have the radiuses configurable @ady624 ?

I feel there are just as many people getting false arrivingAt/departingFrom because of 2 reasons:

  1. The DH is allowing very low horizontalAccuracies to update the app. I have updated the DH locally to try to only accept when my horizontalAccuarcy is as low as 10M and I am still getting arrivingAt/departingFrom changes even though I am 100M + away from the outer edge of the geo fences. It is accepting horizontalAccuracy of 150M even though I am trying to filter them out.

  2. The geo fences in some cases are way to big. I get that some people feel they need to be this large because of false events, but via my log files I can see that it goes both ways. I am not the only one struggling with pistons that are cancelling because we drive on the outer edges of our arrival geo fence and get events within milliseconds of each other which is causing the pistons to cancel. Yes you could put some band-aid on the pistons, but this is still only a band-aid.

Can we please address this?


I could be totally wrong, but everything I’ve read and know from some level of experience is that making the circles smaller will cause false arrivals and departures to increase. This is because our phones/GPS aren’t really able to be that accurate consistently. I understand your desire to make your circles smaller because the roads around your home are creating issues, but I think your requested changes will make matters worse. For you, I hope I’m wrong.


I have been watching the GPS (horizontalAccuracy) via debug and I can get reliable 25M or less accuracy. In particular when I arrive at my house and the wi-fi connects. The accuracy goes as low as 5M.

The other problem is that the geo fences are taking actions when the accuracy is 200M+.

I am only asking to have it configurable because there isn’t a one size fits all.


Still no green presence sensor button:


Then you must have a presence sensor installed already… maybe under some random name so you missed it in the things list.


I have had my phone listed as a presence sensor for quite a while now.

I removed it just in case that was the issue, but webCoRE still did not give me the presence button, so I restored the phone as a presence sensor.

Other than that nothing that could be seen as a presence sensor shows up anywhere in ST.

Also, under “Available Devices” in the webCoRE app, my phone is the only item listed in the “presence sensors” category.

What do I try next?


None of that makes any sense!

If your phone is showing as a presence sensor… then what’s the problem???

WebCoRE won’t let you set it up again until you delete the one it setup previously.

Edit: do you mean you setup your phone as a ST presence sensor, not a webCoRE presence sensor?


Yes, the phone is set in ST, not webCoRE. Sorry if I wasn’t clear about that.
I would think that this would not cause the issue I am having.

I’d like to try using the webCoRE presence sensor.

If webCoRE thinks there is still the original incorrectly set up presence sensor, I don’t see any listing for it anywhere.
If this is what you think is going on, can you suggest a way to find it and remove it?

I’d remove and reinstall webCoRE if that would clear out everything, but that is a pain in the neck that I would like to avoid.
Thanks again for all the help you have offered.


Try deleting the webCoRE mobile app and re-downloading it from the app store.

This will not effect the webCoRE instance installed in the ST cloud.


That did it!

Thanks for all your help.


I had the same problem and this fixed it. Looking like there is a bug in the mobile app. Deleting and reinstalling the app was the only way to get the presence sensor “add” back


Question: if the IPhone is issued by a user’s place of employment, are there any potential exposures of ST/webcore security in the event the phone would need to be turned in? Would the presence sensor need to be deleted? Would any accounts on the iPhone need to be deleted?