Mysa not working with Webcore?


1) Give a description of the problem
Trying to create a task for Mysa thermostat, drop-down only shows Location commands (non-device).
The thermostat shows up as a device in the device list.

2) What is the expected behaviour?
Expecting device tasks in the drop-down, such as set heating point etc. I had a mysa thermostat set up
in a piston previously. So fairly certain device tasks for a thermostat showed up at some point?

3) What is happening/not happening?
Drop-down only shows Location commands (non-device). As if it doesn’t understand it’s a thermostat.
It’s added as a thermostat in the webcore smartapp under capability group 3 - which thermostats (heating). It doesn’t show up under “which thermostats”


Might be a device handler issue, can you track down the device handler you used with your other device that worked?


Unfortunately, I don’t think so.

I had some issues between the classic and new app when trying to add the second Mysa thermostat and ended up having to reset the whole house, lots of fun. In that process, I foolishly also reset WebCore and didn’t back up any pistons. So I have no idea what was used before. Rookie mistake.


Just noticed that no smartApps recognizes them as thermostats. Keep me Cozy and Keep Me Comfortable both shows “There are no devices of this capability” in both classic and new app.

Seems like the issue lies with Mysa. Perhaps they updated the device handler and broke all smartApp functionality. I’ll shoot an e-mail to their support.


@twinklemagoo I can confirm that the problem is something related to Mysa. I have the same (or similar) problems.

When in the smart things app, the icon shows up as a thermostat, but that is about it. I have a number of problems

  • In Webcore all I can see on any mysa device is the status and it is always null
  • Any smart app I have tried does not recognize them as thermostats
  • In the Classic app, when I click the Mysa Smart Thermostat Smartapp I am prompted with a message “Somethings Wrong!”

I was planning on posting something to their facebook group to see if the problem has to do with how I connected them.


none of the new cloud integrations, including Mysa, work with legacy Groovy smartapps like Webcore.


@prjct92eh2 Thanks for clarifying, If I interpret that correctly the only way that the I can generate a complex automation between my thermostats and other device would be to use a custom automation in the updated ST app?


That is correct. It’s kinda like a webCoRE extra extra lite :stuck_out_tongue:


That’s really disappointing. I will have to think about it but without webcore or some form or programming I am not sure that I could integrate what I want. I think I could get there but suspect it will be flaky and unreliable.


Update from Mysa.

After a few days of back and forth with Mysa support and countless “can you try turning it on and off again” :slight_smile: the rep eventually spoke to the dev. team and this is the explanation I got.

"I spoke with our software team, and they have informed me that Mysa isn’t recognized as a thermostat. The Keep Me Cozy automation, is actually to use a different temperature sensor than the one Mysa uses.

Unfortunately we don’t support writing of the room temperature, only reading. Thus it’s not available.

In other words, Mysa doesn’t support being told a different temperature than it reads. I’m so sorry about that!"

At this point I’m really confused. The thermostat is clearly capable of writing room temperature as in setting a heating point. Since the Smartthings app is doing that just fine?

prjct92eh2 Isn’t hue running cloud integration as well?

I’m able to roughly replicate my two main automations without using WebCore or any other smartApp. The only issue is that automations running in the new smartthings app are incredibly unreliable and seem to work less than half the time.