Piston Catagory


I made a new piston catagory “Testing Stuff” that I want all of my new pistons to be assigned to automatically. But the new ones always default to “Nothing Selected”. Can I make them default to Testing Stuff?


Mine always default to a Category I call Misc. I am not sure why. I was looking to see if I set something but I can’t find it. I think that was the first category and I created.


Through a little testing, I found the default can’t be changed but you can rename the default category. So if you rename ‘uncategorized’ to ‘Testing’ now all your current pistons will be in ‘Testing’ and all new pistons will default to ‘Testing’. Seems like the only way you could do this is rename and then move all your existing pistons. Then new ones would default to this renamed ‘Testing’


In case you missed it, I elaborate a bit in my two earlier posts


@WCmore, I really did search for that. Thanks for the reminder…


OK, I must be missing something here. I cannot get my pistons to create in any catagory except “Nothing Selected”. When I save them without assigning them to a catagory, they are saved in “Uncategorized” and “Uncategorized” is not listed in Settings. So I cannot change the name of “Uncategorized”.


Strange… One of my instances still defaults to “Uncategorized”, and it IS shown in my:
Settings > Categories


Side Note:

IF you have more than one instance, the default may be different in each


I just confirmed in all three of my instances…

They each have a different name for the default category… Such as:
but in all three instances, they were definitely available to edit in:
Dashboard > Settings > Categories


I had that thought also. So this morning I closed all of them. I still cannot change things. I am currently on a work computer and maybe that has something to do with things. I will check when I can get back to my home computer.


If your IT admin has cookie software running, then the Dashboard cookie may not stick when changing instances… Meaning, the settings may only show a single instance.

If this is the case, then using a “normal” browser in a “normal” environment should allow you to edit all instances properly. (one at a time)


Side Note:

  • Do not change instances while in the Settings panel.
  • Go all the way back to the Dashboard to switch instances. (buttons at the bottom)
  • Only go to the Settings > Categories once the new Dashboard has fully loaded.


Did my last post help, @Pantheon?


No. Still getting the “Nothing Selected” catagory with new pistons. If I do not select a different catagory, it gets assigned to Uncategorized and Uncategorized is not listed in Settings. I am at a loss.



Just to clarify, did you try changing instances from the main Dashboard, and then go into Settings?
(changing instances while in Settings does not work for me)


I logged out of all instances and logged back into only one instance. I even logged into a private browser. No change from above.


Please bear with me. I think you may want to try connecting all your instances to a browser that is not private. (we want cookies to be set properly)

Once you have all your instances available in the Dashboard dropdown menu, then I suspect you will be able to switch instances from the Dashboard (thereby setting the cookie) and then check the settings.

IE: If you only have one instance registered, then you cannot use the dropdown menu, so a new cookie is not set.

Just a hunch…

To verify that the cookie is being set properly, I would check the list of Categories in all of your instances. (although only switch instances while on the Dashboard)


I am only running one instance.
Can I backup my pistons and uninstall webcore and then load my backups and have everything as I left it?


I am also getting this in the ST log for webcore


Did you have more than one webCoRE instance in the past?
By “instance” I mean: Phone > ST App > Automation > SmartApps > (how many webCoRE here?)

I am asking because an earlier response led me to think you had multiple:

My thoughts using different words:
If you had more than one instance in the past, but only have one instance now, then I think the cookie issue can be resolved by registering again, and then switching using the dropdown menu to set the cookie.

Alternatively, if you have never had more than one instance, then please ignore everything I have said here, LOL.


Only one instance running presently. I had another instance in the past…Webcore Tiles, that I have deleted tonight.

Do you mean this dropdown?