RESOLVED: New webCoRE Installs with NEW ST Mobile App?


In order to install webCoRE into a new SmartThings system from within the SmartThings Mobile App, you must be logged into the SmartThings Mobile App with the Primary/Owner Samsung Account; the ‘Custom’ section in the SmartApps area of the SmartThings Mobile App isn’t even available while logged into the SmartThings Mobile App with an Invited Member Samsung Account (Some of us are running two separate Samsung Accounts and invite the one that is NOT an ‘Owner’ of a SmartThings system as a ‘Member’ of the one that is so that we can have a level of separation between our SmartThings universe, and our general IT gear universe for things like mobile phones, smartwatches, etc).

Is it still possible to get webCoRE up and running in a new ST account today that hasn’t had it in use up till now yet, or did losing the Classic version of the ST mobile app put a complete stop to that?

I noticed a couple mentions of commenting out line 950 in the SmartApp code, but when I did that, I got an error msg in the IDE interface when I told it to save after the edit that started with the following…

“org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:<br/>script_app_metadata_…”

If not directly, then is it still possible to add the new ST Hub to a ST account and location that already has webCoRE up and running, and use webCoRE with that new ST Hub that way somehow?


i don’t believe you need to edit out any lines of code at this point.

to install and use with the ST app (after adding the code in IDE):


OK…I already noticed where you pointed that out to someone else, and went there, but… It’s simply not available in the app to add.

In the section named, ‘Installing webCoRE’, when it says…
“Open the SmartThings app on your mobile device…”
Which version of the app does it mean?

When I open the new one, and go to the SmartApps, there is no ‘Custom’ section, and no matter how many times I click on any of the available options like menus, three line burgers, or whatever, there doesn’t appear to be any way of getting to a page where I can see webCoRE in order to choose it.

What am I missing (I assume there must be some point I don’t understand…or maybe I’m just completely spacing off something that I already know lol )?


there is only one app now.

are you going to the dashboard and clicking on the + (plus) in the upper right of the screen and selecting Smartapp and scrolling down untIl you see custom smartapps? if you are not seeing it there, you should start over and make sure you followed the steps exactly when adding the custom code in IDE at i.e. all 4 webcore smartapps installed and published and OAuth enabled for the webcore smartapp


Oh my…OAuth…um…well…even though I have been through this stuff enough over the years to be in a position where I should have known to go do that, since it’s not in the documentation specifically designed for installing webCoRE (I just went back and searched, and it’s not there lol), I didn’t do it.

Going to do that now, and will edit this comment to let you know how that goes…

OK, it’s still not there after enabling OAuth for the main SmartApp (I forget…Do the others need it?).

Do I need to reboot, or anything?


What installation instructions are you using? seems pretty good to me though I see the video still talks about instead of the correct to access the IDE.

Those instructions explicitly mention OAUTH and include a link to instructions for installing in the new app.


I thought I was using the officially designated documentation, but I don’t really know at the moment.
However, I was able to do everything in this comment, but it’s still not showing up in the NEW ST Mobile App…

I went back to my open tabs in my browser to see which sets of instructions I used, and here they are (both links)…

When I went back earlier to search that page for OAuth, I instead searched for 0Auth, and that’s why it didn’t show up in my initial search results after jkp pointed it out.

Anyway, besides revealing that I have no idea where that name/acronym comes from (lol), I did actually do it.


Well, I figured out two things just now…

  1. There IS an important difference between what the Primary/Owner Samsung Account and An Invited Member Samsung Account can access and do in the NEW SmartThings Mobile App (I specifically asked, and was told that the Invited Members would have absolutely the same control of the SmartThings system in question).

  2. In order to access the Custom section in ‘Add SmartApp’ within the NEW SmartThings Mobile App, you must be logged into the NEW SmartThings Mobile App with the Primary/Owner Samsung Account.

Thanks, All.
I haven’t actually done it yet (came here to update first), but I’m about to, and will report back with my progress…

Of course, it installed, just fine.
I’m even able to access it in the SmartApps section within the ST Mobile App while logged in with an Invited Member Samsung Account. :slight_smile:
So, I think I’m good to go now.

Sorry if I missed it somewhere, but if it’s not in the instructions that you created yet, would you be willing to add the point about needing to be logged into the ST Mobile App with the Primary/Owner Samsung Account in order to install webCoRE, and that it won’t work when logged in with an Invited Samsung Account?

Although perhaps my situation is different (using two Samsung accounts to manage my HA AND life stuff (i.e. I no longer wanted to have the Samsung account on my phone be the one that is tied to my ST system as the owner. So, I created a new Samsung account to be the owner, and invited the one on my phone to be able to still manage it from my phone), I assume having a note about it will no doubt be relevant for someone at some point.


It’s working.
I successfully created my first Piston in this new webCoRE instance;
using the press of a Fibaro Keyfob’s #1 button to run an Alexa Routine that turns a Merkury light bulb on.

Thanks again, guys. :slight_smile:


Interesting. Having a separate account for ST is something I wish I had done and that I often suggest.

I can see why an invited account wouldn’t be able to install webCoRE if it was published by the primary account. I’d rather expect it to be able to install it if it was published by the invited account itself though. I’ve never tried it though.


It was you that suggested it to me over on the ST forum.
I’m so glad you were willing to post your thoughts on my thread about thinking through my new setup. It obviously makes so much sense.
Sorry for not crediting you here.

On that note (that is, thinking through a new setup), is there a thread around here for ‘best practices’ for how we build out our webCoRE system from more experienced/skilled/knowledgeable people?

I mean, I actually still have quite an extensive, and elaborate setup in my handful of webCoRE instances in my original ST setup (which I will be migrating to the new setup as I get to each automation, etc), but I’m always open to more input.

Actually, the Invited account is simply now my old Samsung account, which definitely published it for itself when I initially got webCoRE going in my old system. So, that’s a no-go; the installed webCoRE SmartApp is indeed available for configuration, etc to the Invited Member once it’s in there, but it must initially be installed by the Primary/Owner account.


I’ve just done some testing with a random SmartApp. If an Invited Member creates and publishes a custom SmartApp in the IDE (taking care they have selected, and are working on the correct shard for, for the required SmartThings Location), then that Member can go on to install that app to the Location (I used the web portal as I don’t have a mobile app for my Invited Member yet). Once installed into the Location it can then be accessed by the other Members (though the mobile app needs a little nudge before it notices).


That’s cool.

[First of all, thank you, so much! It’s immensely helpful to have somebody else walking through it with me.]

So, there’s clearly some other variable that we haven’t pinpointed yet, because, like I said, in my case, the invited account had indeed already published the app in question (webCoRE), because until now, that’s the only Samsung account I’ve ever had, and it’s the one I used to publish it originally when I first got going with it years ago.

I may have published the webCoRE SmartApp to my SmartThings system prior to the time when I started using my Samsung account to manage my SmartThings account.

So, even though it is true that it was my only Samsung account, it’s not true that it was the only account of any kind that I used to publish SmartApps.

OK…here’s the next glitch in this logic…

While it may be true that the invited Samsung account did not ever publish the webCoRE SmartApp in the old system, it definitely published others…many over the years, and yet, it’s not just that this one app isn’t showing up, the entire ‘Custom’ section is completely missing, and none of that Samsung account’s previously published SmartApps are available to install.

The ‘Custom’ section only shows up while the Owner Samsung account is the one logged in (I have the two Samsung accounts logged in separately, each on their own dedicated, late model, Galaxy, Android smartphone).

The only SmartApp available in the ‘Custom’ section is the one (webCoRE) that the Owner Samsung account published.