Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy

rooms
manager
automation
occupancy
rules

#783

Hello, new Rooms Manager user here. freshly installed and published the 4 smartapps via github. I create the application as instructed then go into create a new room. I enter only the name and click save and it gives an error saving page message. Any ideas what I might be hung up on?


#784

Did you try saving again? It happened to me a couple of times.


#785

it probably does. create a rule with vacant state to turn off switches? :slight_smile:


#786

please share the error from the ST IDE live logging.

if you are saving it with just the name and its erroring most likely cause is not all the components are installed. need to install 1 DTH and 4 smartapps for everything to work.

its broken up into 4 smartapps so it does not become 1 really chunky smartapp. :slight_smile:


#787

Think I got it figured out.

The error was:

These are the smartapps I had published:

I was missing the Device Handler piece from the Github repository. Added that and all is good now.


#788

If I’ve got this right…

Rule Type: > Execution Rule
Which State: > Vacant

but for “Lights And Switches To Turn On”
I would put the kitchen light as

Turn ON which switches: > Kitchen Light

So this will NOT turn on the light at all, but only turn off that light?


#789

Turn OFF which switches: > Kitchen Light


#790

in Webcore I had created a rule where if I enter a room the lights turn on by motion. However, if I toggle the light switch off and then on while in the room the lights stay on permanently. What is the best way of going about re-creating that with the Rooms Manager?


#791

to solve this the engaged state came about. so occupied is a transient state where you are in the room do something and leave the room. whereas engaged is a perpetual state you are in the room but not moving around enough for the motion sensor to sense it.

not knowing the devices in the room its harder to give a specific recommendation. but take a look at the engaged settings for the room that will give you a sense of which devices can be used to set the engaged state and timeout settings for it.

happy to answer questions about any of those settings or discuss if you have another idea on how to set the engaged state.


#792

It seems as though the Rooms Manager app has ceased functioning for me entirely. Motion Sensors are no longer triggering rooms to change from vacant to occupied.

Currently, using Rooms Manager v0.99.1. Issues started after having that version number being displayed in the application. I have tried to save all the apps as you state in your update posts but nothing has worked thus far. Not sure what else would be causing the issue for all rooms to cease operating.


#793

please update to the latest driver and all 4 smartapps … then go to settings for rooms manager and each room and save them and check if they start working?

some of the subscriptions had changed with 0.99.1 so if the settings were not saved after update of all components it might be the cause of issues like this.


#794

All smartapps are up to date according to the IDE. Went into each room in rooms manager and saved the settings but the motion sensors are still not triggering any of the room.


#795

It seems like motion sensors are registering movement and relaying that to Smartthings, but no information is being sent to Rooms manager.

EDIT: For the time being I am able to get rooms to trigger to occupied by using a Webcore piston to set the rooms to occupied when motion is detected. This then triggers the timers to function as set in rules; however, under the settings for the rooms they not showing has having room motion active during this time.

The settings for each room has the motion sensors set as a room device and the settings have been saved, but I am only able to get the rooms to function through a webcore piston that triggers occupied based on motion.


#796

if you check the issues from dec 21st … does it seem related to the issue you are having?

https://status.smartthings.com/


#797

Doesn’t seem related to that. The only part that seems to be dysfunctional is this fact that rooms manager no longer uses the motion sensors assigned to the rooms. By using a webcore position to turn the room to occupied I was able to get lights to turn on and rooms to turn to occupied. Once the status became occupied the timers took over in room manager and changed to checking -> vacant; however the status for motion detected for the rooms never changes.

The only thing I can think to do is uninstall the app and redo all the rooms because I have no idea why this is happening. I just don’t feel like redoing all the settings I have in rooms manager.


#798

no need to do that. lets start with a simple check … pick any one of the rooms then from the IDE go to my locations -> smartapps then scroll down to rooms manager -> room and click on the room name. then scroll down on the window that pops up to the event subscriptions sections. please post a screenshot of the subscriptions section.

thought this dec 21st issue might have been causing some of what you were seeing:

Monitoring - The issues with connecting and controlling devices via the SmartThings apps, automations controlling devices, and Hubs showing offline or disconnected have drastically improved. We are continue to monitor the situation and will update with any changes.
Dec 21, 18:34 EST


#799

Sorry for the delay, and thank you for the trouble shooting assistance. Hope you are having Happy Holidays!

I took a look at what you suggested, all event subscriptions for all of my rooms display none in the my locations > smartapps > rooms manager section. (Screen shot below)


#800

no worries and same here. anytime. merry christmas has been getting in the way … btw merry christmas! :smile:

can you please open ST IDE -> live logging in a browser window and go to ST app -> rooms manager -> pick any one room and save the settings for the room.

  • on saving the room do any errors show in the IDE logs?
  • for that room are there any event subscriptions now?

#801

I think you got it! You are so good at walking people through trouble shooting, I always learn something new every time!

The logs showed an error with the DTH. (Below)

I checked the device handler and noticed it was showing edited under the status. Went in and published the DTH and saved the settings for a room. All subscriptions now appearing. Tested on other rooms as well, subscriptions showing up again!

As always, Thank you Bangali for the amazing assistance with troubleshooting and continuing to support this amazing app!


#802

updated to github with following changes:

Version: 0.99.3

DONE:   12/22/2018

1) standardized color notification routine
2) added asleep from and to times in asleep settings
3) various bug fixes and optimizations

- **REQUIRES SAVING ROOMS MANAGER AND ALL ROOMS CHILD APP SETTINGS AFTER UPDATING CODE. REMEMBER TO UPDATE DTH/DRIVER CODE ALSO.**