Solved: (Command Optimizations) - Reset dimmer routine not working as expected


#1

I have a piston created to reset my dimmers to 100%. Basically using DIMMER -> set level to 100% -> turn light back off. LED bulbs flash briefly, incandescent lights don’t have enough time to even show light.

The problem is WebCore is skipping sending the “Off” command because it would make no change to the device. Or so says the log. So I am left with all the lights turned on in the middle of the night.

Can someone shed some light on how to make this piston execute the task to turn off the lights?
It runs during the night, and of course the action turns the light on briefly.

12/6/2017, 4:14:59 AM +103ms
+1ms ╔Received event [Home].time = 1512555300000 with a delay of -897ms
+135ms ║RunTime Analysis CS > 21ms > PS > 37ms > PE > 76ms > CE
+168ms ║Runtime (38990 bytes) successfully initialized in 37ms (v0.2.0ff.20171129) (167ms)
+169ms ║╔Execution stage started
+185ms ║║Cancelling statement #2’s schedules…
+201ms ║║Executed physical command [Driveway Lights].setLevel([100]) (9ms)
+201ms ║║Executed [Driveway Lights].setLevel (12ms)
+212ms ║║Executed physical command [Front Step Light].setLevel([100]) (7ms)
+213ms ║║Executed [Front Step Light].setLevel (10ms)
+217ms ║║Executed virtual command [Driveway Lights, Front Step Light].wait (0ms)
+218ms ║║Requesting a wake up for Wed, Dec 6 2017 @ 4:14:59 AM CST (in 0.5s)
+224ms ║║Fast executing schedules, waiting for 496ms to sync up
+738ms ║║Skipped execution of physical command [Driveway Lights].off([]) because it would make no change to the device. (3ms)
+739ms ║║Executed [Driveway Lights].off (4ms)
+744ms ║║Skipped execution of physical command [Front Step Light].off([]) because it would make no change to the device. (2ms)
+744ms ║║Executed [Front Step Light].off (4ms)
+748ms ║║Cancelling statement #13’s schedules…
+763ms ║║Executed physical command [Hallway Entry Lights].setLevel([100]) (10ms)
+764ms ║║Executed [Hallway Entry Lights].setLevel (11ms)
+773ms ║║Executed physical command [Kitchen Light].setLevel([100]) (7ms)
+774ms ║║Executed [Kitchen Light].setLevel (9ms)
+808ms ║║Executed physical command [Living Room Lamp].setLevel([100]) (31ms)
+809ms ║║Executed [Living Room Lamp].setLevel (33ms)
+820ms ║║Executed physical command [Living Room Light].setLevel([100]) (9ms)
+821ms ║║Executed [Living Room Light].setLevel (11ms)
+825ms ║║Executed virtual command [Hallway Entry Lights, Kitchen Light, Living Room Lamp, Living Room Light].wait (1ms)
+826ms ║║Requesting a wake up for Wed, Dec 6 2017 @ 4:15:00 AM CST (in 0.5s)
+836ms ║║Fast executing schedules, waiting for 491ms to sync up
+1360ms ║║Skipped execution of physical command [Hallway Entry Lights].off([]) because it would make no change to the device. (4ms)
+1362ms ║║Executed [Hallway Entry Lights].off (7ms)
+1369ms ║║Skipped execution of physical command [Kitchen Light].off([]) because it would make no change to the device. (4ms)
+1371ms ║║Executed [Kitchen Light].off (7ms)
+1418ms ║║Executed physical command [Living Room Lamp].off() (44ms)
+1420ms ║║Executed [Living Room Lamp].off (47ms)
+1441ms ║║Skipped execution of physical command [Living Room Light].off([]) because it would make no change to the device. (15ms)
+1443ms ║║Executed [Living Room Light].off (21ms)
+1449ms ║║Cancelling statement #17’s schedules…
+1484ms ║║Executed physical command [Master Bedroom Closet].setLevel([100]) (17ms)
+1487ms ║║Executed [Master Bedroom Closet].setLevel (20ms)
+1523ms ║║Executed physical command [Master Bedroom Light].setLevel([100]) (32ms)
+1524ms ║║Executed [Master Bedroom Light].setLevel (35ms)
+1536ms ║║Executed virtual command [Master Bedroom Closet, Master Bedroom Light].wait (1ms)
+1538ms ║║Requesting a wake up for Wed, Dec 6 2017 @ 4:15:01 AM CST (in 0.5s)
+1547ms ║║Fast executing schedules, waiting for 494ms to sync up
+2482ms ║║Skipped execution of physical command [Master Bedroom Closet].off([]) because it would make no change to the device. (3ms)
+2484ms ║║Executed [Master Bedroom Closet].off (6ms)
+2490ms ║║Skipped execution of physical command [Master Bedroom Light].off([]) because it would make no change to the device. (3ms)
+2492ms ║║Executed [Master Bedroom Light].off (6ms)
+2496ms ║║Cancelling statement #5’s schedules…
+2514ms ║║Executed physical command [Master Bath Light].setLevel([33]) (11ms)
+2515ms ║║Executed [Master Bath Light].setLevel (13ms)
+2520ms ║║Executed virtual command [Master Bath Light].wait (1ms)
+2522ms ║║Requesting a wake up for Wed, Dec 6 2017 @ 4:15:02 AM CST (in 0.5s)
+2536ms ║║Fast executing schedules, waiting for 489ms to sync up
+3060ms ║║Skipped execution of physical command [Master Bath Light].off([]) because it would make no change to the device. (5ms)
+3061ms ║║Executed [Master Bath Light].off (7ms)
+3066ms ║╚Execution stage complete. (2896ms)
+3068ms ║Setting up scheduled job for Thu, Dec 7 2017 @ 4:15:00 AM CST (in 86397.83s)
+3195ms ╚Event processed successfully (3195ms)


#2

Use options in the top right hand corner and then click, show piston settings.

On the piston you will now see lines for:

settings
end settings

Click settings and then click the little cog to the bottom right.

Set command optimisations to “disabled”

This will send the off command even if the lights are already off.


#3

Exactly what I needed! Confirmed the rule worked as expected last night after disabling command optimizations.

This community is amazing to be part of. Thank you!