Trouble installing webCoRE - "Your location is not correctly setup"


#1

I’ve followed this guide for the IDE:

And tried to follow this guide for the SmartThings App:

https://wiki.webcore.co/New_SmartThings_App

I do get all the 4 webCoRE items in the SmartApp section, and I am only trying to install the actual “webCoRE”-SmartApp.

But I get stuck installing - the description is:

“Your location is not correctly setup”

and “Please follow these steps to setup your location timezone”, followed by 6 steps. I tried, but to no avail. It just “reloads” the install page with the same error and I get a “Cancel” and “Next” button at the bottom. Cancel obviously cancels installation, but next just reloads again and again.

How do I proceed?


#2

Have you set your geolocation in the new app? Click on More Options (3 dots in the upper right of the screen) on the main dashboard and select Manage location


#3

I did set up my location by moving the pin - the address detected was my neighbors house, but that should be fine …


#4

BTW nothing about timezones anywhere :stuck_out_tongue_winking_eye:


#5

Timezone only shows in IDE at this point @ https://account.SmartThings.com under Locations > home

I forget how to set up timezone… setting up smart lighting does it I believe… I need to check that.

Tagging @ipaterson

Edit: install smart lighting and set up a rule that uses sunset/sunrise and it should set your time zone.

Question… did you set geolocation in Classic or new app? If Classic, try setting from the new by opening and clicking save.


#6

In ST?

I only have the new app - I already tried dragging the pin around and setting it down and saving … It still complains.


#7

yes, click on + (plus) in the upper right, choose smartapp and select smart lights. the app will install and be located in menu (3 bars in the upper left) in smartapps

if you still don’t get your time zone, contact ST support and inquire how to add it


#8

ST is acting weird. When I pick “Sunrise” it asks me to set my location. I do that and press save, but it hasn’t been configured :confused:


#9

yep… I believe you have reached the point where you need ST support to intervene to set that info for you.


#10

Thanks, I will contact them! :slight_smile: