Unable to create new WebCore Smartapp


Hi - I recently discovered I’m not able to install the WebCore smartapp when I select it from the Marketplace. When I select it, it goes to another page with a spinning circle and then says “Oops something when wrong”. I did recently update to v0.3.10a20190223 so not sure if that is the cause. I do have a previously installed instance of the WebCore smartapp that seems to be working so this only seems to be affecting new installs. Has anyone else seen this before? The below is what I get from live logging.

Not parsing XML message:
<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<u:GetVolumeResponse xmlns:u="urn:schemas-upnp-org:service:RenderingControl:1">


Try signing out of the Classic app and log back in


That didn’t work. I get the same “Oops something went wrong error”. :frowning:


did you publish all the smartapps when you updated them in IDE?


No, I only published the main WebCore smartapp, the others are only saved.


Here are some screenshots if it helps

IDE showing smartapp install

What happens on phone when trying to add a new instance of Webcore


The bottom 3 Smartapps are showing status as not published. Open each of them and publish for me.


Okay, just published the other 3 smartapps, but I’m still getting the “oops something went wrong” error


Check in IDE and see if you only have one location.


Yes, there is only one location


try signing out of the classic app and logging back in


This is really strange. Signing out and back in didn’t work. I just duplicated all four smartapps in the IDE and added the letter “a” to the end of the version so I could tell them apart. I only published the main WebCore smartapp, tried installing and it worked!


Got it working again! Ended up going to the main WebCore smartapp in the IDE and selecting Oauth > Update.