Variables appear to be erased, but not really while editing on iPad



@ipaterson. I know you got a lot of stuff going on with upcoming features and all.

However, ever since the release with the ability to rearrange variables while editing pistons, I have noticed a bug. This only happens when using the iPad, which happens to be on iOS 12. When editing a piston from chrome or the mobile app, sometimes if you touch a variable with your finger, or move your finger across the variables; they will disappear. It looks like they have been erased, however if you save the piston they come back.

It is a little annoyance I can live with, but it is there just the same.


I see this all the time on my iPhone using Safari. Not on iOS 12 beta either.


I noticed this on iPhone yesterday and plan to fix it for this release. It’s good to hear that you can save the piston without affecting the variables, I ended up cancelling and very carefully tapping on a different part of the variable to edit.


This should be fixed in the mobile app (once your app’s browser cache refreshes) and will be published for the live dashboard in the next release.

I was able to get the same behavior on desktop by clicking and dragging anywhere to the right of the variable text. The line itself was starting a drag despite being marked non-draggable. I noticed that all the other places that use drag handles apply the drag to “inline” rather than “block level” HTML elements so I moved the dragging around to a span element which is inline.


Is there a way to refresh that cache on mobile app? I closed app re opened and issue still exists? I tried logging out and back in same result.


Not that I know of on iOS, it just takes some time.


The fix for this was just released in v0.3.108.20180906 so it should now apply to both the mobile app and the dashboard viewed from a mobile browser