Authentication required help


Been a month or two since I’ve been in webcore. Am I doing something wrong?
I go into my smartthings app on my phone navigate to my webcore app, and tap on register a browser. I copy the passcode and enter it here

Everytime I do that, nothing happens, I’ll hit enter or click authenticate after I put in the passcod then the page refreshes, and acts like it took the info, but does nothing and I am stuck back at the page waiting for a passcode.

I’ve tried doing it from my phone, and from my laptop and getting the same results.


Dang it, I hope I didn’t just screw it all up.

I went into device handlers and my smartapps updated and published and now all the entries turned black, not green. grrr… I don’t want to have to do a full install again and loose everything.


There are no devic handlers in IDE for WebCORE, only 4 SmartApps

Take that back - there is a presence sensor :slight_smile:

The black color is good, it means your IDE and github are updated to the same version.


Open the ST app, go to Automation: SmartApps, your WebCORE instance. Click on settings and choose clean up and rebuild data cache. Then try to register


Thanks, but that didn’t help.


what browser(s) are you using on mobile device/laptop?


Chrome, let me try Firefox


try incognito tab in Chrome. do you have Privacy Badger extension installed in chrome?


I don’t get it. I did it in incognito, and got a different screen below, which when I plug in the passcode I get from the app gets me to the next screen which is the same screen I’ve been seeing all along and I don’t know what passcode to use for that.


The first screen, you use the register a browser code. The second (Authentication Required) is the security password you set up in the WC instance in the ST app. If you forgot it, you can change it in the same settings section where you cleaned up data cache. but choose Security.


Thank You! Thank You!!!

That was frustrating…
I made sure to add that to my LastPass password saver…


The same problem as above is presenting itself except with the following difference.

When trying to change the password in the Smartthings App on my android phone the following error is displayed “Error - bad state. Unable to complete page configuration.”

When logging into webCore on chrome (tired incognito and regular) the webCore page loads, but none of the pistons are displayed and bar in the top left corner of the screen that displays the name of the location of your webcore instance displays "\loading… .

The good news is all of the pistons are still working, the bad news is i’m unable to edit any of them.

Tried to clean up and rebuilt cache multiple times and it always says “Something’s Wrong We can’t load your screen right now”

Any ideas or suggestions are greatly appreciated.


I tried all of the above on a different phone and everything worked like a charm. Once I changed my webCore password I was able to log back into webCore and the pistons were all displayed.

I uninstalled and reinstalled the SmartThings Classic app on the phone that was giving me issues and all of the errors went away so it appears to be a bug in the classic app that was causing the issue.