Can no longer save anonymized screenshots on iOS



Seems as though since Apple did away with 3D Touch capabilities there’s no longer a way to save piston screenshots. I’ve tried long pressing many times and no luck.


Since it does work in the mobile web browser (tap to download the image) I suspect this would require an app update to fix. Not sure if @ady624 is planning to update the app for any of the new ST API stuff, but if so this fix may be worth considering.


Well don’t I feel silly. I’ve been long pressing the pictures for so long I’d never even thought of just tapping on them. Tapping does open new tab which then allows me to save. Thanks.

Also curious is anyone else having issues with iOS app no longer working? @ady624 is aware of my issues but curious if anyone else has similar problems. Safari works fine but iOS app won’t get past logo.


I tried both tapping and long pressing, maybe I need to go back and try that again :blush: I feel just as silly you now


Just try a single tap on the anonymized screenshot and it’ll open a new tab in Safari.


I will try it next time I am in the app, thanks


Doesn’t work on iPhone 11 Pro Max.


Yep it doesn’t work in the app, just in a standalone browser like Safari or Chrome.


Ah, I will try it in the browser nest time I am using it, thanks for this