Can't delete piston



So, I decided to remove all of my lights from Smarthings and WebCoRE (due to some reorganizing) and now I can’t delete or do anything else with my piston - it’s stuck there. No error messages given.
Also tried to uninstall given sub-smartapp - just got an unknown error.
Also, everything depending on this piston can’t be manipulated in SmartThings.
Hub restart did not help. Help please!


What error message do you see in > Live Logging when you try to delete the piston?


There was completely no error in the log.
Also, I have an update…I tried to do factory reset on my hub, seems like I can’t remove the location either. So it looks like it’s more problem of SmartThings than WebCoRE. Not sure if it should be here than.
Alreaedy wrote on ST support.


I also have a location in my Hub (V2) that I cannot delete. I just named it “Old” and have been living with it there as it doesn’t seem to really bother anything. I got my hub from my son who had set it up for himself but never got a device so he never really used it. The old location is his old location which I changed but have never been able to delete. I did remove him from the account once I had control of the hub.


With your “Old” location (2nd Location), make sure to remove any/all Modes, remove any/all devices, and remove any/all Groups. You should be able to delete it after that.


Did almost all that…but it seems the last thing I can’t delete is “Home” mode, thus I can’t delete the location :/. Just gave me error 500.