Can't get SMS notifications to work


1) Give a description of the problem
Send SMS Notification does not work.

2) What is the expected behavior?
Receive a text message when I hit test. Number is stored as +447######### (I am in UK)

3) What is happening/not happening?
Not getting a text message

**4) Post a Green Snapshot of the piston![image|45x37]


What is executing your piston?


Just tried it here in UK, this works for me:

Not sure why I have curly brackets around the variable and you have square ?

Is you phone number defo correct, I just missed a digit…


just me hitting the test button. I actually put it in a different piston originally, triggered by a motion but it didn’t seem to work. I created this just to fault find.


Yeah definitely the correct number, I have put it in a dozen times now. Tried with just 07… then with 00447… then with +447… have tried them all several times. Will try GFs number tonight and see what that does.
I must admit I have never used SMS before in a piston, so quite possible I have done something wrong but it looks that straight forward I don’t see how.
The reason your brackets are curly is that you have defined the phone number as a variable and called that variable in the send SMS command. I just typed the number into the command directly.

I have tried it your way now but still not working.

Weirdly, I have now tried it with GFs number and it works! Why not mine then???


OK, this is REALLY confusing me. Can anyone confirm if SMS messages received from ST/WebCore actually incur a fee? That is the only thing I can think. My mobile is actually a company mobile and has been slightly limited on use, such as having the explicit content filter on and can’t send MMS messages.
I can only imagine that if SMS messages from WebCore cost to receive then perhaps my company have set up a policy to reject this kind of message.

Anyone able to chime in on this?


I have not experienced that first hand, but if it is a company phone, then they most likely have the ability to censor anything they want to. (similar to how many company computers cannot access certain websites)

If you can install apps on that phone, one possible solution is to install Google Voice, and use that new number to receive texts from your SmartHome.


Yeah I can install apps. I’ll probably give that a go.

I am baffled by how/why this would be censored. I can’t see that my company would choose to block their phones from receiving texts from WebCore. I’ve had the phone for 3 years now and have not come across this sort of thing before despite the fact I am always playing around with this sort of thing. I receive messages from IFTTT and Stringify all the time and I would presume these would be blocked if there was some sort of censor on the account.


It could be as simple as them blocking inbound texts from a certain country… or the SMS could have a header somewhat similar to a MMS, so it is being blocked for that reason.

If your boss (or IT specialist) is cool, maybe throw that question at him.

If you go the Google Voice route, you might want to choose an American phone number. I can confirm that that works beautifully.

One added benefit with Google Voice is:
It will be transferable to any new phone you buy later on down the road.
(and can actually go to multiple devices you own simultaneously)


OK, so this evening I got the first message from WebCore. I haven’t attempted to send another test message for a couple of days at least. This has gotten SERIOUSLY stuck somewhere.
If this is the result of the first time I sent a text then it has been a full 5 days! Perhaps not quite good enough to alert me when there is an intruder in the house!


It really sounds like all messages are being directed (and filtered) thru your company before they reach your phone. You may have to resort to a third party texting app.


OK, So I just had to follow up on this as I have now sorted the issue.

Or in fact there really wasn’t an issue at all.

So, having never used the Send SMS notification feature in WebCore before, the first thing I did was to set up a new piston as a test. I added on action which was to send an SMS to my phone number with the text “Test”

It didn’t go through.
I tried again a few times, changing the format of the number and reading everything I could to see if anyone else got the same issue.
5 days later I got an SMS saying Test (I hadn’t even tried that evening).

Today I tried again but this time I changed the text to $now so I could see exactly how long it take to go through.
It went through instantly.

So it looks like there is some sort of Spam filter on my SMS and it has filtered out these messages as there was no real content.
I have now put the command into the piston I actually wanted to use it in and it is working very well.
I always like to test things before I implement them. I guess it doesn’t always pay off!


Great detective work!!

When working with new code (or a new device), I often test before making my code complex. Personally, I think this is time well spent…

I usually use $time and $dayOfWeekName to help me keep track of sequential tests.


Sorry to dig this tread out but what number format did you find works?

Having exactly the same issue with not receiving sms…

Also what number do you see them coming from? is it a USA number or something else?



What region are you in? US?


Never mind just seen that ST have stopped SMS from working outside of USA -


There are some alternatives available for you to try…


I have been wondering why this hasn’t been working for a while too.
Found the post about ST canning SMS and got really annoyed. So have now found @RobinWinbourne’s thread to work around it.

It looks really complex but really it isn’t and it works fine. Don’t be put off by the lengthy description of how to do it, it only takes 15 minutes.
You get a free trial to the total of £15 but after that you will have to pay. I am still on the trial at the moment.

Thank you @RobinWinbourne, good work.