Can't load dashboard


When I go to I get an “Error loading dashboard” and it redirects me to the registration page. When I get a new registration code from the smartapp and enter it, I get the same error again.

webCORE Dashboard Completely Broken. Please Help [UndeclaredThrowableException]

In the ST app, go to Automation: SmartApps and select your webCoRE instance. Tap on settings and then choose Security and either choose a new password or re-enter your existing password, choose Next then Save. If that does not resolve it, go back to Settings and choose Clean up and rebuild data cache. See if that helps.


I’ve reset my password in the SmartApp. I’ve done Clean up and rebuild data cache. I’ve cleared the webcore cookies and file cache in my browser. I’m still getting the same error. One interesting thing I just discovered is that if I go to, I get the error I posted. If I go to and click “Go to the dashboard”, I get a 522 timeout error, indicating that the webcore server is not responding to the Cloudflare servers.


mobile device? have you tried it on a desktop browser?


I’m using a desktop browser - Chrome. Worked fine until yesterday (maybe day before).

ETA: Just tried it in Edge and it was OK. I’ll play around with Chrome some more.

ETA: Turned off my Chrome extensions and it’s OK. So it would appear something changed in one of the extensions which is now breaking webCoRe. Thanks for the help.


just curious… try incognito tab in Chrome


Looks like Privacy Badger is the culprit. I disabled that, and it worked fine.

ETA: Yep. Re-enabled it and refreshed the page, and it was broken; disabled it and refreshed again, and it was fine. Whitelisted the site and reported problem to EFF, the source of the extension.


Similar issue here. I have disabled all extensions, reset cookies, etc. and still no dice.


You are getting the same error code as above? Have you tried a different browser?


Yes, I have tried Edge.


more details, I can’t figure out


OK, I have tried it on Chrome and Edge, with no luck. I may just be missing an account setting or some such. The different accounts get a bit confusing to me, since I only go back into it every few months when I want to add another device.

I have two hubs, so that is another source of potential confusion. I’ll try logging into my SmartThings account and approaching from that point of view somehow.



It is a different Error number, but same basic result. I had recently changed to a manually set IP number on my LAN, so I was thinking that might have had something to do with it. So now I have gone back to DHCP assignment, with no luck.

Next, I will try to get a new activation code from my phone app. Maybe there is just a simple disconnect in that process.


Your image shows you have, you should be using


How was this resolved (May 2018)? I’m having the same issue now.


I can only speak to my own problem from last year. I use the Privacy Badger extension in Chrome and that was preventing the dashboard from loading. I whitelisted the site in Privacy Badger and it worked fine after that.


If the user is getting the error shown above then they are going to the wrong URL. As noted above, only will work for the dashboard.


When I go the dashboard (, it asks for a password (“Please enter a password for Home / webCoRe”). I thought the only way in, was to get a code from my mobile app, but entering that there does not work (does nothing, just asks again). I don’t have another password. And if I go through the page (“Go to the Dashboard”), I get the 522 error. Any guidance would be greatly appreciated!


yes, there is a code to register your browser and yes, you created a password to use :slight_smile: In the ST Classic app, go to Automation > SmartApps > your instance of webCoRE > Settings > Security, If you forgot the password, you can reset it. then use and forget about