Can't Register Browser or Create Pistons


I was having some issues importing a backed up piston, so I tried in another browser, but when I tap “Register a Browser” in the ST app, it comes up with a blank white page. I have searched and others have said to reinstall the four SmartApps, so I tried that and I’m still having the same issue. I have OAuth enabled on “webcore” only, as I did before… things just stopped working. I have rebuilt cache as well.

EDIT: Within my dashboard on my phone, I am unable to create pistons either.

Can’t get ST app to give browser code

I’m having the same issue. Blank page trying to register a browser.


Chiming in, I have the same issue where I couldn’t create a piston. I tried the following without success:

  • Cleared cookies
  • Changed browser
  • Rebuilt cache
  • Logged out on the browser
  • Press the “register a browser” button in the smartapp and it returns the blank page


Well, I’m glad to find out it’s not just me. Not happy to learn that there’s no way to restore backed up pistons. Hopefully this can get solved soon.

I have uninstalled and reinstalled the entirety of webCoRE three times now, rebooted Hub, cleared cache, everything else that I have seen suggested. My SmartApps within my IDE are all black… if you need any other information let me know.


I am having the same issue


Could the webCoRE server be down.
Any ideas @ipaterson


The SSL certificate has expired, I’ll push this up the chain to get it renewed ASAP.

Can’t get ST app to give browser code

I am new to webCoRe and was trying to get the code to create my first piston on my laptop. But when I go to the smartapp to register the browser I have the same “white page” and no code.


Same issue here


Back in business, folks. Sorry for the interruption!


Thank you!