Discourse iOS App API Error


I haven’t found one


There is indeed, it’s bad but does do notifications. https://itunes.apple.com/gb/app/discourse-app/id1173672076?mt=8


Of course, I searched for discourse and it didn’t show up but when I search for discourse app it appears.




Has anyone been able to use it? I get site not found error…


@Kebel871 the discourse app?


Yup, for iOS. I tried both “community.webcore.co” and “https://community.webcore.co”. No luck!


Mine worked on my phone weeks ago, and I went to add iPad, and same deal. Never figured out why, but phone still works…
That said was this previously working for you and just stopped? We just applied a site update an hour ago. Want to know if related.
Or were you just trying to set this up now and it doesn’t work?


Thanks for your help as usual :slight_smile:

It’s a fresh install on iOS 11 GM. Never used it before.


Ya, then this has been a problem I can’t find a resolution to. I’ve cycled the forum’s API key, and even to test assigned myself a specific API key. No avail.
I just assigned you a form specific API, see if it works


Still can’t get passed step 1


I don’t know if I’ll have any luck, but I’ll dig a bit further when I have a bit of time


Thanks! I’ll do some research too and see if I can find anything useful apart from that thread: https://meta.discourse.org/t/add-a-new-site-android-was-not-found/66589

It’s android related but problem seem similar.


I got it added but when I click log in nothing ever happens.



Tried playing around with URL and got a different error this time


Updated to latest some 6 hours ago


There has to be some site setting either in discourse or the hosting causing this.
Don’t think discourse as the only requirements for the app are TL1 and above, and site API key enabled. Both are.

What’s weirder is when I first enabled the API weeks ago, I linked my phone’s discourse app, and it’s still working, but I can’t add the site to discourse app on my iPad.
This is an odd issue


My guess is that safari doesn’t like JavaScript


Even trying to use meta.discourse.com doesn’t allow me to log in.

So the problem is probably not a setting we have on our side.


Maybe not helpful to add a meeeeetooooo post … but yeah I am new to using discourse as I typically dont read / reply to forums on my ipad but I gave it a shot to use the search box (see Forum Search Box Borked and was not able to register community.webcore.co but community.smartthings.com worked just fine