External Web Requests Failing


#1

Sometime during late in the evening of the 5th of February 2020 (GMT+2), all of my pistons which were sending me notifications via my own Telegram bot have stopped working with the following error:

Error executing external web request: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

These are GET requests to https://api.telegram.org/bot0000000000000:secret/sendMessage?chat_id=xxxxxxx&disable_notification=true&text=message

The url gets calculated correctly - when i copy the calculated url from the logs and manually visit in Chrome it works. The pistons have been working like this for many months - actually the last message that passed through was at 19:20 on 05/02/2020 (GMT+2).

There does not seem to be any issues with the certificate of api.telegram.org (it has been active since May18 and expires May20). I did no changes to the piston’s code, the certs seems to not have changed so I am at a loss!

Any ideas?


#2

the same error. Earlier it still runs normally

2/8/2020, 9:37:45 PM +525ms
+4ms ╔Received event [Home].test = 1581172665522 with a delay of 3ms
+62ms ║RunTime Analysis CS > 22ms > PS > 32ms > PE > 7ms > CE
+70ms ║Runtime (37552 bytes) successfully initialized in 32ms (v0.3.110.20191009) (62ms)
+73ms ║╔Execution stage started
+78ms ║║Cancelling statement #5’s schedules…
+84ms ║║Executed virtual command setVariable (1ms)
+93ms ║║Sending external web request to: api.telegram.org/botxxxxxxxxxxxRXxWmkQI/sendMessage
+299ms ║║Error executing external web request: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure
+300ms ║║Executed virtual command httpRequest (208ms)
+303ms ║╚Execution stage complete. (229ms)
+304ms ╚Event processed successfully (304ms)


#3

Problem still ongoing… any one any ideas?


#4

Tried swapping the call to api.telegram.org to a testing website on one of my domains (SSL cert provided by LetsEncrypt) and i get the same error

so it seems to be a problem with not just Telegram (and its SSL cert provider)…


#5

I am using a POST request to my TinyCam server and it is working. Also making several GET requests to my GoogleSheets logging spreadsheets and they are working.


#6

I just noticed that my GoogleSheet logging piston is also not working:

|+685ms|║║Sending external web request to: https://script.google.com/macros/s/xxx/exec?
|+10721ms|║║Error executing external web request: java.net.SocketTimeoutException: Read timed out

PS:
I am on graph-eu01-euwest1.api.smartthings.com