FIXED: Chrome: WebCore Overall type: Unknown_Type server type: No_Server_Data Dialogue Error


I’m seeing this new WebCore error message “Overall type: Unknown_Type server type: No_Server_Data Dialogue Error” in MacOS Chrome Browser.

I am current on the latest version of WebCore at v03.107. If I click again in the area where the overall type: UNKNOWN error is located and select ‘expression’ or any other WebCore action, WebCore acts as expected. I have ‘Log Out of WebCore’, closed the Google Chrome Tab that WebCore was using, cleared Google Chrome caches, Quit Google Chrome, cleared caches using ccCleaner app, and rebooted. I still get this same error in all pistons and any selected entries in the WebCore dialogue function drop down…

Any thoughts or anyone else seeing this error since upgrading to the latest stable version of Google Chrome on MacOS?

Here are the screen shots of the error:


I tried it on Chrome on my Mac and everything appears fine. I normally use Firefox.


Thanks @jkp. I think this WebCore error started appearing after the new Google Chrome update to:

  • Version 69.0.3497.81 (Official Build) (64-bit)

I’m on MacOS 10.13.6

I’ve cleared all Chrome’s browsing history, and rebooted and still see this error. I guess I can start looking at plugins, but I have not installed any new plugins or ad blocking.

I just tested on Safari and this new error does not appear, again pointing to possibility that the new Chrome version induced this dialogue error with the new version.


yes, that is the version I have


ok, thanks for confirming. I can still code, it just requires that I click the drop down box several times and then I get the expected choices. Interesting that Safari does not show the same error.

I updated the title so if others start seeing this, we can dig further.


When you say logged out of Chrome do you mean that you clicked the Log Out button on your webCoRE dashboard? If not, try that.


Thanks @ipaterson. I performed the following actions without any change to the same error in the WebCore dialogue dropdown actions on the left side. Here are my exact steps.

  1. Log Out of WebCore
  2. Close WebCore Chrome Tab
  3. Clear All Browsing Data from Time Range ‘All Tine’ in Google Chrome History Page
  4. Quit Google Chrome Application
  5. Run ccCleaner Application to clean any other cache
  6. Shutdown & Restart MacOS
  7. Launch Google Chrome
  8. Create New Chrome Tab
  9. Launch WebCore Dashboard URL
  10. Obtain WebCore Token & Login from Mobile client
  11. Edit different WebCore Piston
  12. Create or revise a WebCore command, like ‘SMS message’ and see the same error appear

I did test WebCore from MacOS Safari application and did not experience the error.


But did you say webCoRE backwards three times while standing on a chair?

I’ll take a look today, this is bizarre.


Does the same happen in Chrome incognito mode?


@ipaterson: Yes, just tested a piston from Chrome Incognito, resulted in same error. But when I select the blue drop down again and select anything, the dialogue box displays and functions as expected. This issue is probably hard to diagnose, since I may be the only one reporting it {for now}, and therefore perhaps it’s just something occurring in my zipcode (Ha!).

Again, MacOS Safari works perfectly as expected, but I am a devoted MacOS/iOS Chrome user (for now)…


Wow okay, so it’s not caused by a rogue Chrome extension. Would you please open the Chrome developer console (Cmd+Opt+J) while that SMS dialog is open and run this command then paste the result into a reply on this thread?

JSON.stringify({...$('designer parameter').scope().operand, config: null})

Also this

$('designer parameter select').html()


Nevermind, here is a better lead. See this comment from a similar bug report on a different open source project.

You would disable that “Show autofill predictions” setting by going to the url chrome://flags/#show-autofill-type-predictions in Chrome. However, since this lets me reproduce what you are seeing I will take a quick look at whether it is fixable on our end.


@ipaterson . WOW you are amazing :muscle:at finding a needle in a mountain/haystack of code. I did happen to enable those new flag features in Chrome when I upgraded based on a technical security article I had read about enabling them. Goes to show, leave things alone!

I set these two flags back to their default states in Chrome and re-tested WebCore! FIXED!

Setting the default state for Show AutoFill Predictions and Force-Saving of Passwords corrected that issue of the error that I was experiencing… I can live with these settings in their default state!

Thanks AGAIN for wonderful support!


Chrome is steadfastly refusing to respect any of the existing practices for disabling form autocompletion in HTML. I am not able to prevent Chrome from adding all that data to the form but I did find a way to prevent selectpicker from displaying it instead of the selected value. This will be in today’s release just in case this setting gets automatically toggled on for anyone else.


The fix for this was just released in v0.3.108.20180906


This has been reverted due to problems noticed here:

There is another way to fix this that doesn’t seem to have any side effects, but I’ve learned my lesson for today. The alternate fix will be tested for the next release.