"if already on" failing


I just upgraded to version 0.3.108 two days ago. After upgrading, my pistons that contain the “if already on” parameter are failing to check if my lights are on when running.

For instance, for the piston in the screenshot, I have WebCore dim my lights slowly in the evening if I’m not doing anything (there’s no movement). This has worked fine for the last year, but I upgraded to 0.3.108 and now it doesn’t check if the lights are off anymore. I tried adding an extra line to check the light status twice, where it says:
{$device}'s switch is on
is a new line I added to try to work around this, but it does not work either.

So, what is happening, is my lights are continually turning on. Because, it is adjusting the brightness without checking if the light is on (which turns the light on). Obviously, I couldn’t sleep with my lights turning on every minute, so I had to disable WebCore.

Is there any way to downgrade to the prior version?


I am not sure about the code change, but you can PAUSE a single piston without having to disable all of webCoRE. Just go into the offending piston, and above the Edit button you should be able to PAUSE that piston… It will not ever run until you unpause it.



There are no changes related to this in the last release, were you upgrading from an outdated version? Please consider anything else that may have changed our any other automations that affect these lights.

Do you see the correct switch status for these devices in a simple piston? For example one that logs the switch status whenever it changes.


Thanks! I’ve paused all my pistons that were checking switch status.

I’ll see about logging the switch status and see if it is able to read switch status in a simple piston.

I logged into Webcore to set up some a new presence sensor, and edited a couple of pistons in the process, but not the ones related to lighting. When I logged in, I was also suggested to upgrade my Webcore, which I did. I believe I wasn’t more than a month out of date.

That night was when the pistons started failing to operate as before.


This appears to be working again for what it is worth