MAJOR ANNOUNCEMENT: 2000 Community Users & Brand New Dashboard!


confirmed on chrome and opera - fully updated versions. cheers!


Thanks. That’s done the trick.


How do I fix this?

When I go to ST, select webCoRE smartapp and select Save, I get “An unexpected error occurred”.
If I click on CoRE Dashboard in ST, I get this:

Where do I find he code for this?

Also, it looks like I have 2 copies of the weCoRE Dashboard smartapp.

Looks like I need to delete one of these copies of Dashboard. How do I do that?

Any assistance would be greatly appreciated.


you Need to figure out which copies of WC are in use. Write down version from your dashboard.

Then open the actual code by clicking on it in the ide. If you’re on version C in the dashboard, and you have 2 copies in ide of version B and C, you can delete the B version cause you know it’s not in use.

Then add the git repository if not already done and sync it


That warning message is for old CoRE, not webCoRE.


Hey since we’re on the subject of duplicate webCoRE smart apps - I’ve also got a duplicate dashboard. Believe I already know which one is the one not in use, but cannot get it deleted in SmartThings app or IDE.


I’ve also got another question: are you supposed to be able to save snapshots from iOS app yet? Feature still doesn’t seem to work but thought I’d put it out there anyway at least as a feature request.


In the past, I had such an issue. It took a ST case, but they resolved it next day or so. They can delete anything on their side as you might imagine.


You can save snapshots in iOS Safari, but not iOS Chrome… there’s various reasons for this and it’s unlikely change I’m afraid.


Have you shared your location with any other users.

I did a test a while back and shared one virtual account with another… played havoc with shared DTH and smartapp code overlapping and I had a seriously hard time deleting anything, and couldn’t even unshare the account!

I had to go through and delete every device from one of the accounts before I could break the link and delete a smartapp!!


That seems like it may have solved the 1st issue.

Still not able to delete either version of webCoRE Dashboard in the IDE.
Both are v0.3.000.20180224, and the IDE will not let me delete either of them, “because it is installed by one or more users”.

I could use some assistance deleting either of them (or both and reinstalling one).


Instead of trying to delete it from the settings in the ‘my smartapps’ tab… maybe try going to locations, installed smartapps, edit. And delete from there instead.


I found this under locations as you suggested:

I deleted the 1st instance because the 2nd seems to be the one I want to keep.

Still have 2 webCoRE Dashboard in the IDE.
What does it mean that one is listed in green print, the other black?

Can’t access webCoRE from the tile in ActionTiles on my PC.

No longer have webCoRE in ST on my phone.


Your wisdom is limitless I swear! On that page I uninstalled as you suggested then went back to the other list of smartapps the went in and deleted where this fine it allows me to do so. Thanks!


where in the IDE you see two dasboard apps? I only see one in the screenshot above.

You do however have two instances of webCoRE itself installed.


You are correct. I meant to say webCoRE.


You can have as many instances of webCoRE installed as you like… this is different compared to @GRClark’s problem (he had two copies of the dashboard smartapp code installed in ‘my smartapps’).

You have pistons installed in both your instances of webCORE, so if you want to delete one you need to clear out the pistons first.


I do still have 2 instances of the dashboard

This is getting frustrating. Until this morning, everything was working properly.
I saw the post about the new dashboard and decided to try it out.
Now I can’t get to my pistons.


Putting the two copies of the dashboard code aside for a second.

Describe the process you are following to access your pistons and where you are getting stopped.


If I open ActionTiles and click on a tile that normally opens webCoRe ( for me, WebCoRE doesn’t load.
I get the spinning squares in the lower right corner of the screen, but my pistons never appear.