Mobile app for webCoRE


#103

I take it this is the reason the dashboard is now asking for location permissions? This is in Chrome on W10.


#104

Oi. You lot are getting greedy. lol. :smile:
What about us Android peeps with no IOS. (Some might call us sensible).
Plus I’m in the UK so that’s a double handicap. :wink:


#105

Yeah that’s a good one. Can’t compete with that… Or can I? I’m from Canada after all :stuck_out_tongue_winking_eye:


#106

If needed I am available for Android testing.


#107

I am willing to help with Android testing.


#108

No work has been done towards the Android app yet - does Android still work with the Eclipse IDE?


#109

I don’t know what the Eclipse IDE is,


#110

http://www.eclipse.org/downloads/packages/eclipse-android-developers/neonm6


#111

I tested a very simple piston that didn’t trigger when I left a place identified at work for lunch.

if presence_sensor presence changes
then push notification “WebCoRE presence changed”.

Am I missing something? Last executed is never but recent activity for presence_sensor shows a line with “leaving work” and then “place is”


#112

Presence only reflects the “home” place - the one place you set as default - if none is set as home/default, then the first on the list is it. You may want to use

if currentPlace changes away from "Work"

where Work is the name you gave your work place.


#113

Oh ok. Good to know.

I also think I exited inner circle but stayed within the outer one, which would explain the entries in recently.


#114

Beta testing for the iOS app is now open to everyone - send me a private message with the email address, first name and last name. Try to use the email address you have setup as your iTunes account.

PLEASE READ THIS FIRST

BIG WARNING: THERE IS A CURRENT ISSUE WITH SMARTTHINGS THAT CAN CAUSE COMPLETE LOSS OF YOUR WEBCORE INSTANCE - READ BELOW
It appears that deleting the last remaining child device from the ST UI app leads to removing the app as well - without any warning or chance to cancel - this is a “feature” of ST and I am working with ST to fix this - it happened to me, added a presence sensor, then removed it from the ST Device List - that lead to the webCoRE app being completely removed, along with all the pistons I had. So I STRONGLY RECOMMEND that until ST fixes this, you install a new blank instance and use that one for the presence sensors. Ye be warned.

READ THIS TOO
WARNING! If you setup a presence sensor device using your main webCoRE instance and then later delete that device from ST, you will loose all your pistons in that instance, as well as the instance itself. Please - PLEASE! - install a blank webCoRE instance, import the DTH from the Device Handlers repository webCoRE - same as you did when you installed the webCoRE SmartApp, then install the iOS app from TestFlight and login with a registration code for the new instance - go to Settings, tap on Setup sensor in the Places tab, pick a name for the sensor (you can safely change this later from ST) and hit Save - that will create a presence sensor in your ST app, provided you correctly created and published the DTH - you do not have to create any virtual devices, just make sure you publish the DTH, webCoRE will create the devices for you.

Thank you


#116

Lol. Sounds like a new policy is coming from cosmo’s Fingers soon.

Emails only in PMs
Lol


#117

Non-Campbell’s soup post :rofl:
This afternoon my presence did not update (it did this morning), when I went into the webCoRE app it asked for location access again… I thought that was odd, but after I granted it I “arrived”.
Just thought I’d share.


#118

Just downloaded the app from TestFlight.

Created a new webCoRe instance.

Added the webcore-presence-sensor dth on ST.

Published the DTH.

Logged in to the app using the registration key from the new webcore instance. Approved all messages about location.

Went to Settings, under ‘Places’ tapped on the + sign, map appears (showing my location), i gave it a name and tapped on ‘Save’.

‘Setup sensor’ button appears. Tapped on it and gave it a name and tapped on ‘Save’. (i still see ‘Setup sensor’ rather than the name i gave it.)

Checked in ST and device is not there.

Am i missing anything? Using iPhone 7 Plus on iOS11.


#119

Did you pressed apply after saving? Something similar happened to me and IIRC, it was because I forgot to apply. Might worth a try.


#120

Ensure the DTH is published. Kill the app and try the setup sensor again.


#121

I had this problem too. I was able to setup the sensor correctly on my phone and it showed up.

When I went to my daughters phone, she had to be logged into my Apple ID for TestFlight to see the webcore app. Once she ddownloaded the webcore app and it was on her phone, she needed to re-login to her Apple ID. Then open the webcore app and setup the sensor portion for her phone. It then showed in smartthings. The need to go into webcore settings and include that senses or for presence in order for webcore to use it.

Hope that makes sense

Tom


#122

Confirm that the DTH is published. Killed the app, even tried removing it and reinstalling it with the same result.

Also can confirm that i did hit “Apply” after creating it. The device is still not showing up in ST.

Some screenshots.


#123

make sure your smartapp (in IDE) is up to date and published.
Kill WC iOS app, re open, create new instance.
Then try again. Just walked a buddy through this today. it was his smartapp out of date