New ST app update killed webcore dashboard?


Has anyone tried to register a new dashboard or access their old after opening up the new ST app update as of yesterday. I was curious to check it out, looks pretty nice at first glance. But it said it was updating my controller and now I can no longer get to my webcore instance in the dashboard. Actually, I can access the dashboard but it will not show my instance in the top menu and shows no pistons. Please tell me I’ve not lost everything.

Any help on how to restore or access my pistons would be much appreciated. I have tried this on a few devices and all the same.


Do you have anything for webCoRE listed at > My Locations > smartapps? Normally it would show your webCoRE smart apps and each piston. Also are there any errors showing up in the Live Logging tab corresponding to each time you reload the dashboard page?


Smartapps and pistons are all showing there. Just checked live logging and seeing this…

error java.lang.reflect.UndeclaredThrowableException @line 1700 (listAvailableDevices)

I was working fine on pistons last night. This all started after the ST app said it was updating my controller. Has anyone else tried webcore after opening the new ST app? I have both installed and have previously been able to at least control devices in the new app.


The timing with your app install may be coincidental. Some people affected by this (a timeout from the SmartThings platform not being able to load your devices) have recently added Echo or Ecobee devices which expose a ton of attributes and increase the likelihood of this error. Check the latest comments for recent solutions.


Thank you. I did go through that whole thread and eventually went in and removed a handful of devices. I had to remove some that I’d like to use in pistons but I guess I’ll have to wait until everything is working and then slowly add.

It’s weird because for the past few days I have not added devices and everything seems to have been working ok. Although, I will say I’ve had some executions firing inconsistently with 4 sec wait times reaching 15 sec, so maybe that could be related?


It could be, the problem was very come-and-go for some people depending on how heavily loaded the ST platform was when they loaded the dashboard.