Pistons have stopped working! [daylight savings time issues]



Same here, all my timers went out of sync then then next day once I paused and resumed all went back to normal.

I have been a away for a few days and just come home and nothing worked! Was like aaarrrr it’s the smart home apocalypse! Then checked the IDE and our lord and master of Disaster @ady624 was of course on the ball and has fixed it already! Updated and the house jumped into life! :sunglasses: brilliant!


I was just thinking of downgrading to the previous version of WebCoRE due to the issue subscribing to global variables in the last patch. Will I still be able to do so now?


Nevermind, I managed to test the function, works fine. Will look into the code when I get home.


I tried but couldn’t find handleEvent anywhere in you’re code :sob:


It’s ok, I tested it, returns 7am EST correctly


I think I found the problem. Algebra like next day and so should be performed on local time, not UTC. That’s because 24h from 7pm yesterday is at 6pm today. I should use 7pm local last night, add 24h then convert to UTC. Instead, I am converting 7pm yesterday, adding 24h (real hours) and then convert it back to local and get 6pm, thus the hour off. Not sure the crazy loops should still be around, but I know all will be fine tomorrow. However, every x units should use UTC. Time will shift, but the time intervals will be constant.


Just a heads up, the new version still suffers from the same bug and ST will soon rate limit it. They will remove the rate limits in the morning. I will try and push a proper fix for it in the following hours.


Time is one complicated bitch!!


It appears to have already happened :frowning: Pistons stopped…


Sorry guys, will attempt a fix as soon as I am home. 30 min at least.


Hey. Don’t worry. Family comes first.
I know how to work my light switches, heating etc.

We all survived before webCoRE and a few more hours isn’t going to matter.


I know but it’s that awkward moment when your house stops working… it’s almost like your car not starting, but worse…


Currently I have a Logitech Harmony and Alexa integrated to a virtual location (no physical hub) and zero webCoRE pistons… so I’m not fussed, take all the time you need haha.

Bet my tenants are cursing right now though, with the 70+ devices and 40+ pistons I left them with!!


This is awesome how quickly you’re working on this. Webcore was broken when I got up for work this morning. But my pistons are ran fine again after I updated webcore around 10AM, I think everything originally broke before 2AM. It appears to me that webcore broke when it, before the time change, tried to schedule an event to take place in the past. I have a piston which runs every 10min(and every hour) I’m not sure which (or both) of those schedules was the offensive timer, but when the piston attempted reschedule in the past, it immediately rescheduled and rescheduled and rescheduled to the tune of sending the same event hundreds of times per second, and I imagine this went on for at least 10 minutes, if not a whole hour, leading up to the actual time change when the piston either broke or smartthings just disabled it.

But like I said, it was working after updating. Thanks for your quick work!

EDIT: I think it’s disabled again, because it did not fire this hour… but this time it didn’t break all crazy like I described above. I’m glad you’re working on it!


In this moment the pistons are not working, again. I think @ady624 is working at the fixes…


What’s the most current version?


0fc at the moment but knowing Ady there will probably be another update in the next couple of hours.


Yeah, all pistons stopped working again. Looks like the rate limit already hit.


webCore seems to have stopped working again at around 3:50PM ET


Yeah same here, updated, all ok. Now gone again.