Problem Loading Dashboard Data


Please Help. Im in this endless loop where I cant load my dashboard. I see others posted this and I cant find a solution. I even went as far as buying new hub, setting up new account, removing and re adding all my devices,

Please help, my wife wants to kill me

webCoRE Update v0.3.108.20180906 - restore pistons from backup file, bug fixes


@KiloWatts use


@mzagame did you recently have your SmartThings account migrated to Samsung?


Months ago I did it. But the problem started when I received a message that Webcore needed to be updated of some sort. I must have did the update wrong and then nothing worked afterwards. But I had it working using my Samsung account and new app for months.

Now starting over, im trying to use webcore using a different recently setup samsung account (brand new hub as well). I first install and load webcore to my samsung IDE, then initiate it using the old smartthings app so it shows in the new Samsung app. But regardless from where I try to register a browser from, I received the error above.

Thanks for any help you could offer.

  1. You use to access IDE?
  2. You only have one Home Location showing in IDE?
  3. Did you install from GitHub repository or manually copy the code into IDE?
  4. You installed all 4 smartapps?


Thanks again for your continued efforts and responses. Answer to your questions below. I have set this up multiple times without issue. I cant see where this broke but do see some others have reported this without resolution.

  1. You use 1 to access IDE?
  2. You only have one Home Location showing in IDE?
  3. Did you install from GitHub repository or manually copy the code into IDE?
  4. You installed all 4 smartapps?


Are there any error messages under Live Logging? Usually you will see an error pop into the logs every time you refresh the dashboard in your browser.


Thanks for this advice, I always forget about the live logging.

Here is the error that shows up in my log after I put in my webcore PW

Here is what line (I think its referring too) 2942 shows in my code

Does this mean anything to any of you that may help me?


click on the first app in the image you posted and click publish.


Same errors with it published. I had tried this already as well but did it again to confirm.

Can you let me know what your line 2942 says?


Another user had this exact problem two weeks earlier, SmartThings support had to fix the account and then he had to reset the webCoRE dashboard password in the webCoRE smart app. You can read how that interaction went:

Since this is not an isolated incident it looks like we may need to handle the case of accounts with invalid routines. Please report back once you have contacted SmartThings, this did not seem to be a self-serviceable issue since even the ST app was crashing on the routines page.


I had seen this post but he did see he also had an authentication error which was different.

I cant imagine ST would be so helpful to troubleshot something from WebCore.


Long shot but try creating a ST routine, I know there should be a bunch of default ones in there but worth a try… webCoRE doesent seem to be seeing any right now.

Is the problem you are seeing now the same as the one you had on your old hub / account?


This is the advice we gave the first person affected by this and upon attempting to create a routine the SmartThings app showed the error “An unexpected error occurred” – please do try that but if you cannot create a routine you will have to contact SmartThings support.


Have you tried editing that line of code? Change…

def routines = location.helloHome?.getPhrases().sort{ it?.label ?: '' }


def routines = [:]

It might get you up and running. Also, can you see your routines in the IDE?


Thank you all for your responses. I dont know what triggered it to work but I seem to be up and running.

Ive tried 50+ things in different variations and somehow finally got in after trying for about a week.
Some of the last things I did (but dont remember the order) that may have solved this.

  • Logged out of both classic and samsung apps
  • Added SHM to samsung app
  • Logged back into classic
  • Initiated a PW for webcore on the classic app
  • Got into webcore via the web
  • Logged into samsung app and was able to use webcore app and web as normal

I have no which sequence solved it but thank everyone for their responses.


I have the same problem. I have done many things but I have not been able to access the dashboard.+


A workaround for this NullPointerException was just released in v0.3.108.20180906

@jojara I saw your posts on a few related threads with the same error, can you please update and publish your webCoRE smart apps at and then let us know if you are able to access the dashboard?


Thank´s, that solved my problem.