RESOLVED: Problem loading the dashboard data. The data shown below may be outdated


Ok, nvm, that is not webCoRE. It’s a different app.


I see no other errors. Can you please give me a rough estimate of when it failed last? Or try now and jot down the time if it fails so I can look deeper?


I just tried right now, and got the same problem. :slight_smile:

In SmartThings Live Logging, I see this for webCoRE Pistons (my primary instance)…

“error physicalgraph.exception.StateCharacterLimitExceededException: State cannot be greater than 100000.0 characters”

p.s. I’m all about exploring unknown territory, and often find boundaries I had no idea were there. lol So, I’m sure it’s entirely possible I’ve stumbled (um…or…bumbled) onto something goofy that nobody else usually ever comes up against. :slight_smile:


Actually, I just tried it again while actually watching Live Logging this time, and noticed this one…

‘error Dashboard: Authentication failed due to an invalid token’

So, is that, supposedly, having to do with my browser?

EDIT: Just so you know, the reason I know it’s not that is the fact that I just tried from a browser I’ve never tried before, and got the same thing.


How many pistons do you have? Do you have any piston that abuses the piston state, ie long text for state? I would recommend clearing the cache and immeditely pausing such a piston - maybe move that into its own instance. Also, are you using logs on high details? Try turning those down to possibly none if not needed


Each piston has a hard limit of 100KB… Trying to save a large piston, and failing, is the usually time I see that error…

I usually can resolve it by this sequence:

  • Logging out of the Dashboard in a browser…
  • Clearing my browsers Cache & Offline Website Data
  • Using the ST phone app > webCoRE > Settings > to register my browser all over again…


@ady624 I’m an idiot, and as such, I’m not even sure how to answer.
e.g. I have no idea how I’d know whether, “any piston that abuses the [piston state], ie long text for state?”
I will check the linked doc… (thank you! :slight_smile: )

@WCmore I definitely was trying to save a rather large Piston when I first started experiencing this problem. I was thinking perhaps I should split it into two (or more) smaller Pistons, but once this started happening, I can’t even get back in there to do anything about it.

As for the browser stuff, I have already tried getting in there from multiple browsers on computers where I’ve never even tried to access webCoRE before, and am still getting the problem on them. So, I don’t think that’s going to help.

Is it possible to go in and edit (or maybe even delete) an individual Piston within the ST IDE?


You can clear the state from the smartapp on the phone


Actually, I got in (with one of the browsers I’ve already tried during this troubleshooting), and I am editing one of two large Pistons.

My first task was to duplicate it. Now I’m deleting half of it in one, and then will delete the other half in the other copy.

I’ll let ya know how this goes…


I was able to modify both of the very large Pistons by splitting them into two pieces. That whole time, I was able to move back and forth within the Dashboard, and make all of the changes I needed to get that done, and never saw the error message.

However, then when I went back to my normal browser, and re-registered it with a new code, etc, I still got the error in there.

So, just to be sure, I will clear everything out for that browser, and see what happens…


try clean up and rebuild data cache again


Yep. I did that too. Thank you!
I really appreciate all of the hand-holding from you guys. :slight_smile:

Just now, I went back to my primary browser where I started having the problem, didn’t even log out, but simply closed the browser tab that I still had open, opened a new tab, went there, and it opened for me as normal…didn’t even have to use a new code, or log in or anything.

So, I think I’m back to a good working state. :slight_smile:

Now though, my next task will be to go through all of my (132; that’s 73 Live, and 59 paused) Pistons to see if any more seem way too big that may need to be split into multiple pieces. lol

p.s. You all deserve ‘Solution’, but I could only pick one. So, I picked the one that basically hit the nail on the head (from my limited perspective). That doesn’t mean that’s the one that put the most work/time into this.


You can always install a second instance and move some pistons there. Split the load. You have too many I guess.


OK, cool.
What should be the limit?

Also, what is the best way of migrating Pistons from one instance to another?
Backup codes?


I dunno… I have three instances, with nearly 450 pistons in total…


I usually follow these steps:

  • Pause the old piston
  • Switch instances
  • + New Piston
  • Create a Duplicate Piston
  • Point to the appropriate devices
  • Save the new piston
  • Test the new piston


OK, cool. Thank you.
So, I can duplicate a piston in one instance in another instance?


Yes, just try to make sure that the two are not active at the same moment, or craziness is bound to happen… (two pistons stepping on each others toes)


I believe there was a Move option too? Or was that only planned in my crazy brain? If it doesn’t exist, then yeah, pause and duplicate should work best. Make sure you have the used devices available in the receiving instance


Aha, cool.
So, if I’ve already made the relevant devices available in the new instance, the Piston will just use them as-is without needing to specify them manually?


I still specify (and verify) them manually…

Actually what I do is: On one computer, I view the old (paused) piston, while on the other computer, I duplicate and double check that the right devices go in the right sections.

It makes it a breeze if you can see both at once. (old & new)

If I don’t have access to two computers, then I might use two different browsers to effectively do the same. Or sometimes, a tablet for viewing, and a PC for editing.

I do this because you cannot see pistonB while you are editing pistonA…
(unless you are on another device or in another browser)