RESOLVED: Problem loading the dashboard data. The data shown below may be outdated


Ya, that’s awesome! :slight_smile:
Thanks a lot for spelling it out like that.
Totally makes sense. I will do likewise when I get to that point.


Thankfully accessing my dashboard is back to normal now, but last week I was having to login multiple times a day, kept getting “your devices may be…” I changed my webCoRE password to no avail, changed from 3 months to Never, I posted here but was ignored :sob:

My webCoRE memory is at 50%, if that mattered.
I tend to agree with @WCmore that this strange behaviour started around SDC, I think possibly webCoRE started to behave like a nervous child when Ady started to talk about all these big changes, programs as deep, comprehensive and profound as webCoRE have feelings too.


Sorry, @Alwas
I know how that feels (being ignored on a support forum)…though, pretty much every time it has happened to me, it was honestly more about me being impatient and self-absorbed (I’m only pointing the finger at myself here) than about anyone else actually actively, intentionally ignoring me.

I’m not saying that’s necessarily what happened in your case (I’m certainly not calling you either those things lol ), but in my experience, such occurrences are rarely so cut and dried.

Everyone is busy and has their own life and issues they’re dealing with, and sometimes, especially if there are lots of other threads flying about, things (and occasionally, people) get inadvertently and unintentionally passed over, without getting the attention they need or deserve.

It’s also true that low-hanging fruit are the food of choice and/or at least an easier target for less experienced community members.

i.e. more complex issues sometimes end up waiting longer, because it takes a while for one of the more experienced members to notice and engage.

That above ^^^^^ was just off the top of my head.

However, now that I’ve had a moment to take a look at the thread you linked to, I can say, pretty confidently, there were likely a number of reasons you didnt get the support results you may have been hoping for…

  1. That thread was created by someone else over 4 months ago
    [Recommendation: create new thread]

  2. The original poster was no longer active in the thread; hadn’t even posted in it for over 4 months.
    [Recommendation: Join a more recently active conversation, or start a new one of your own]

  3. The one who stepped in to lend assistance was sort of ignored by one of the people asking for support, which may be frustrating for them
    [Recommendation: This had nothing to do with you, but… Always try to communicate timely when someone lends assistance, and show respect and appreciation for their efforts]

  4. You revived someone else’s thread that had been at rest for over a month instead of creating your own new thread
    [Recommendation: create your own thread]

  5. You only posted once (sometimes persistence via multiple responses over time will catch someone’s eye)
    [Recommendation: Comment (kindly, and in a patient tone) multiple times to try to get someone’s attention]

  6. You did not pose a question (?) or ask for any assistance, directly
    [Recommendation: Be direct, specific, detailed, and ask for assistance, with both wording AND punctuation]

Regardless, your feelings are valid. It never feels good to be ignored; whether intentionally or inadvertently. We are definitely on the same page in that. :slight_smile:


Two different windows of the same browsers should do?


You may be right Adrian, but each time you back out to the Dashboard, you would also have to switch back to the other instance… (since the “instance” cookie was set by the other window)

Using two devices or browsers will effectively “keep” each in the same instance during the whole process…


try incognito for one of the two. no need for a second installed browser. does that work?


I’m getting all kinds of strange behavior (I don’t know if related to OP issue)
-all pistons show error when opening:

Sorry, an error occurred while retrieving the piston data

-loading dashboard shows

problem loading dashboard data

-dashboard shows: {{getLocationMode()}} instead of the usual mode & SHM
-logged out, registered browser again via smartapp,
-now top of dashboard just shows loading, same on desktop and mobile chrome/safari, and chrome incognito mode


Not the same issue as OP. Some things to try:

  1. make sure webcore is up-to-date with latest version
  2. make sure all Smartapps are published in IDE (I.e. none are showing as Edit)
  3. clean up and rebuild data cache in settings for your instance of webcore in the ST app

That’s a start but may not resolve the issue.


Thank you jkp, that has never happened to me before. The ST app smartapp rebuild took care of it.
[edit: I think my piston got too big (27 chunks)]


Indeed…then that may very well have been the same issue as mine (Piston too big). :slight_smile:


That does work… but it requires the extra steps to register the Incognito browser at the beginning of each session.

Alternatively, if you use two different browsers (or devices) then it remembers between sessions. (one click, and I can begin coding)


@WCmore @ady624
This is great! (i.e. the part about figuring out the best, most efficient way of accessing webCoRE from two source browsers at the same time)
Thanks a lot for walking through that, guys. :smile:


Incognito or even clearing data and history for my browser will allow me to get back into dashboard but as soon as I try loading pistons it goes back to spinning logo then afterwards I can’t even load dashboard. I’ve tried Safari, Firefox and Chrome. Same thing happens on each one.


@ady624 this is what I mean.


I hate to keep going on about this but initially I’d wondered if this was an iOS issue since the timing coincided with iOS 13 releases but even seeing issues on Windows PC. Dashboard loads normally but pistons take forever to load, but eventually do come up.


Was this ever able to be fixed? I’m getting the same error message.


I have been having issues for a while as well. Mobile browser (chrome) from Android just sits and spins, and desktop browsers will display a “cannot display pistons” error on login. Refreshing that page asks to reregister the browser and validate again. Ive cleaned and rebuilt the cache to no effect from my Hubitat hub.


@sgnihttrams why are you asking to have comments disabled? Many of us are still having issues including myself.


If you no longer want to get notified when others post to your thread, you can change the setting at the very bottom to anything other than “Watching”…




This thread had NOTHING to do with any service problem.

As stated in the solution, it was all due to something I had done, and the fix was for me to stop doing that, and to change my own behavior moving forward.

Why not let this thread die, and just create a new one for your problem?


I created this thread.

It turned out that the problem I originally had was my own fault, and had nothing to do with any outage or service problems.

It seems silly to me to insist on continuing to use such a thread for some potential actual, real problem. lol