Save piston after editing stays at editing


#1

For some reason, when I save the piston after modification, it stays on the edit mode but if I don’t make any changes or click cancel, it redirects to the view mode which does not include my changes. Even creating new pistons stay on edit mode after saved. Can’t seem to figure out why. TIA


Unable to save pistons
#2

have you tried a different browser?


#3

During the ‘Save’ process, is your ‘Chunk’ count going past 17 or hanging at the end?


#4

I may be experiencing the same issue. I click save and get the ‘Preparing to save chunked piston’. Normally it would start counting the chunks but it does nothing.

That is the issue where your piston is too large which isn’t the case here. It is happening to any psiton I try to save at random intervals regardless of size.

The only workaround I have discovered is to refresh which takes you out of edit mode and to the overview screen. Click edit again and you get the option to open the cached local version of the piston which usually holds the changes. Click save and it saves like normal.

I have cleared cache, tried multiple browsers on different PCs and used private/incognito mode and it still happens. Incidence is random but has occurred more frequently over the last few days.

No errors in ST live logging.


#5

Same issue for me. Cannot save any piston no matter the size or content.


#6

ST or hubitat?


#7

hubitat, go freaking figure


#8

tagging @E_Sch the hubitat expert :slight_smile:


#9

Are there any logs or other errors?

HE console -> Logs, or in the piston logs?


#10

ST for me, happening less frequently, network congestion?


#11

You mentioned you cleared cache… was that for the browsers or your webcore instance? If not webcore instance, open the ST app > menu > SmartApps > your instance of webCoRE > settings > clean up and rebuild data cache


#12

Both actually, should have clarified. Cleared cache on browsers and the clean up and rebuild data cache.


#13

The inability to save pistons after edit issue just started happening to my instance of webcore. The pistion I’m trying to say if 2 chucks big. I tried the following

  1. Clean up and rebuild data cache

  2. Restarted hub

  3. Tried browser in incognito mode (to make sure no browser addons were impacting webcore)

  4. Removed some devices for webcore as this just started happening after I added a light strip

  5. Updated my webcore to the latest version

None of which helped

In my Smartthings Live logging i’m getting the message: smartapp_pause called by smartAppName=webCoRE, value=250, smartAppVersionId=e1c8ae07-4041-4db1-ad33-cf88bfd24d69 that keeps repeating

Any assistance is greatly appreciated, thanks!


#14

I assume you got this fixed. I have been experiencing this with every browser. I can get about 4 edits on a piston, with any browser, before I get to this point. So here is what I have to do with each browser

  1. FireFox - history clear history, open preference and go to security, and clean cache. Log off of WebCore. close FF and make sure all instances of FF are closed. open back up and start over again with registering instance.
  2. Chrome., More tools clear cache then go to setting>security and clean everything there. Close Chrome make sure all instances of Chrome are closed and go through the process all over again
  3. Safari - Need to make sure you show the developers menu and clean cache, clean browsing history…

Alternating between staging.WebCore.co and dashboard.WebCore.co gives you a few more edits but will eventually stops working. I am so into this tool and not getting a lot of help to get resolved so I deal with it. I hope eventually it will be fixed.


#15

I have never seen this, or experienced it.

I assume you are running on HE, and if so I suggest you need to try doing a backup and soft reset and restore of your HE system. I suggest you contact support on how to do this, as it is not hard, and may resolve your issues without having to do a major reconfiguration.

again this is soft reset, not a hard reset. I suggest you contact HE support to ensure this is done correctly.

I assume you are on

  • latest HE firmware
  • latest webcore
  • you are not seeing anything in your logs as far as errors.

I have never experienced or seen, so I’m assuming there is some db issue in HE that a proper backup, soft reset, and restore should correct.


#16

Yep all is up to date. I used this in ST since it was first released and never had these issues. Don’t have any other issues with and other applications. But yea it could not hurt. Just like a windows machine…the three-finger salute always resolves most issues.


#17

@Mckenph the instructions on how I resolved my issue are located here. Unable to Save New Piston

I had to roll back my webcore version to v0.3.110.20191009 and that resolved the issue.