Unable to save pistons


1) Give a description of the problem
I’ve final done the long awaited deep dive into WebCoRE. Today, for some reason,
opening the pistons takes forever and I cannot save any piston. Clicking on save finishes with “Backup Bin Updated” and the editor remains in editing mode. I’ve rebooted the hub and the PC i’m using but nothing is working. Hoping y’all have seen this before and can tell me what to do.

2) What is the expected behaviour?
To be able to edit pistons as normal

3) What is happening/not happening?
The editor will not save the piston

**4) Post a Green Snapshot of the piston![image|45x37]
There is no point sending the piston because it is happening to ALL pistons. They worked two hours ago and now i’m getting nowhere.

5) Attach logs after turning logging level to Full

Again, the issue is saving the piston, not running the existing pistons. That said, everything seems to be crazy slow at the moment.


ST or Hubitat?


ST. As far as i know everything is up to date. I’m starting to get concerned that there is something really wrong here.


This has been happening intermittently for me for a few weeks.

As a work around, attempt to save, refresh browser, go back into edit mode, open locally saved version and try to save. Usually works. I assumed it was a server issue.

The issue was mentioned here previously but it seemed that only very few users were affected


Thanks for the response. For the record I’ve now tried editing the pistons on two PCs and MacBook Pro and it fails to save every time. Now if I edit the pistons on my iPad everything works fine - but the move, for example is a little trying. Everything has been rebooted over and over.
I’m going to continue to fight the good fight but no success to date.


Happening to me now. I have the same exact issue.
I press save, it says it’s saving and finishing up and then nothing.
It doesn’t go back to the dashboard and if I close, reopen the dashboard and click to open it says I have a mismatch between the locally saved and the currently running piston.


Not sure if this issue is addressed somewhere BUT this is also happening here and has tended towards almost unusable. If anyone can point me to a troubleshooting list or similar? A rebuild helped once and then went right back to not saving.


ST platform? saving new pistons or existing pistons or both?

Just to warn you… webcore will probably cease by the end of the year if you are on ST or whenever groovy is shut down. You need to start planning to switch to Automations/scenes in the ST app or look at Rules API.