There was a problem loading the dashboard data (August 25, 2020)


Having the same issue


Not quite black & white, but generally speaking:

  • If the error happens when you are editing or saving a piston, then it may be localized only, and might resolve itself with a “cache clear” and/or log out/in…

  • If the error happens when you did absolutely nothing in webCoRE, then it may be a SmartThing issue, and I would recommend patience while changing nothing.

In my case, it gave me an error while editing, so I assumed it was for me only.
(apparently, I just had bad timing, LOL)

Dashboard Doesn't Load

pistons are on the hub, the dashboard is the editor for the pistons


Same issue here. I thought I was going crazy trying to debut it. Probably coincidentally, the issue started when I saved a short piston using a new device handler.


same issue… earlier this morning it was fine… then later i went to edit a piston and got the message.


In Italy WebCore is down …


2:11:33 PM: error physicalgraph.api.StatusCodeException: Invalid http status code returned: 401 @line 950 (api_get_base_result)

2:11:33 PM: error Dashboard: Authentication failed due to an invalid token

2:11:30 PM: error Dashboard: Authentication failed due to an invalid token

2:15:58 PM: error physicalgraph.api.StatusCodeException: Invalid http status code returned: 401 @line 5054 (initIncidents)

are the errors i get when i try to register a browser to view my pistons


Unfortunately, I was tinkering around trying to figure out how to do some new stuff so I definitely thought it was localized. I spent an hour frantically trying to fix it before the yelling family started.


Hailing from Cambridgeshire in the UK, dashboard is down as well. Spent the last two hours assuming I screwed something up with my 8 little pistons. Let’s hope it clears up soon.


I’m in the same boat, I thought it was something to do with my migration to the new app.


this info may be of use and it may not, but i thought i would tack it in…i use some smartplugs by meross. great little plug…until they stopped working right the other day…lol … after looking in the meross app, it instructed me to unlink and then relink the meross service. that worked and they work correctly now.


Not working in Poland as well.


Yes, Meross released their new ST integration on August 24, 2020. Recommendation was to unlink the old me and relink to Meross to gain access to the new integration.


That is an issue with line 950 of the webCoRE SmartApp where it is loading active SHM incidents. That just seems to be used for cosmetic purposes and I don’t think you need it.

I think they may be side effects of the other issues. I had them but they suddenly went away when I logged in from my mobile app.

That is the piston fetching info about the SHM active incidents. It is done in several places and is part of opening the piston for editing. I think you can probably just comment out the contents of initIncidents() in the webCoRE Piston SmartApp (lines 5052-5054).


I tried commenting out line 950 in the WebCore code. It did allow the the WebCore dashboard to display again - however, when attempting to opeb a Piston it just hangs on the screen with the WebCore logo in the middle with the spinning circle under it.


OK. Same problem here in the UK.
Best thing I can do is go to bed and hope its fixed in the morning.
G’night all!


Yep, looks like the piston needs editing too as it is hitting a similar error. I can open pistons for editing now.


What line number(s) did you comment out in WebCore Piston? 5054?


I got tired of waiting on ST, so I commented out line 935, and now I can get back to my dashboard!

Thanks a bunch!


I did the previous two as well. See post 12.