There was a problem loading the dashboard data (August 25, 2020)


That worked - back in business. Thanks for the help.


Also having the same issue. Just migrated to new SmartThings app today too, so I thought it was that. Have reconnected GitHub, cleared browser cache, registered browser again to no avail.


Any possibility that this may be the end result of Smartthings phasing out the legacy SHM as part of the push to get everyone over to the new framework?


Ah yes, I should considered that the line numbers may need adapting if you are running different versions of the code.


It is a reasonable thought. I think SHM is still potentially active if you haven’t migrated but who knows what happens once if has been removed?

There have also been things going on with device status and history being turned off in the legacy environment (scheduled for the 17th though I only noticed a lot of the effects this week), and there is also the question of whether accessing SHM related stuff like this was ever documented in the first place.


August 17, 2020

The new SmartThings app will be the single location for all event history:

  • Some historical events will no longer be available in the SmartThings Classic app and Graph.
  • Device status and history for Samsung Products will no longer update in the Classic App.
  • Historical device events that do not match the new Capability Schema will not be accessible to Groovy SmartApps.


I have not yet migrated from the classic app but intend to do so soon.

I just opened my classic app and I notice that the SHM section ‘home solutions’ will no longer load. It was still loading yesterday.

It’s seems that they have done something to SHM which has caused the webcore dashboard loading issue. The other things and code tweaks that people have posted are related to SHM so it’s a fair assumption it’s related.


Making manual edits above has fixed it for me.


commented out 950 in the main app and 5052, 5053, 5054 in the pistons app as described up above. i can get into my dashboard and edit my pistons and they test ok. yay!.. now what?


The fix that @derfaust stated works now, apparently, a cached version without the line numbers being commented out was still active!

I feel like this is yet another reason to seriously migrate to another local processing platform that starts with an ‘H’


Commented out line 950 in the webCoRE and lines 5052, 5053, 5054 in webCoRE Piston. 100% up and running again. Thanks!


I have the same problem in Utah, USA. I’m using the New Smartthings App and migrated several weeks ago. All was good until today. The commenting out lines in the Main Code and Piston Code have me back up and running. (950 in the Main App Code and 5052-5053-5054 in the Piston Code).

Many thanks to those that found a solution.


Worked for me too. Thanks all.


I added a UX suggestion to this bug thread: Dashboard broken

It appears that SmartThings is changing things that cause issues with the webCoRE dashboard, so I think some simple enhancements to the dashboard error message will at least more effectively remind us to check status (provide a link) and not assume it’s us. Also, an updated, more helpful error message dialog will really help new users who will likely be even more confused.


I see some people are modifying the code. Exactly where do you do this modification? I’ve been looking all over the webpage and I can’t find some of these line numbers. I’m using Firefox on Windows 10 just in case that matters.

Thanks for any assistance.


I don’t suppose there might be anyone with commit access who could implement those changes on GitHub?


Login to IDE at and go to the Smartapps section

Edit the files noted, save and publish for me.


It only takes a few seconds to do it ourselves…

IDE > My SmartApps > ady624 webCoRE
IDE > My SmartApps > ady624 webCoRE Piston

Then search, type, save, and Publish “For me”.
(Using this post as a reference)



Just a question. If I make these temp fixes in the code, all should still go smoothly once these are implemented directly into the GitHub repo and I pull the new version correct? I know it’s a dumb question. Just want to know if I should just wait for the official fix or just do them now.


I think the worst that will happen is that the IDE will notice that there have been changes on both ends and make you aware of this.