Triggers no longer fire on any of my Pistons


So not sure what happened, This all started yesterday. Seems non of my Triggers will fire on their own. I first noticed none of my timed pistons fired. At first timer scheduled were not set. So, I re saved them and then they were scheduled but when time came and went they still dint fire. Still shows scheduled even though they are in the past. If I run a test on them then it read the scheduled timers and executes set next timer and doesn’t run. The same holds true for switch or presence triggered pistons. When the switch is triggered its like WB cant see it. If I run a test then it sees it and executes. Press switch again and nothing. Ive checked the setup in ST and all thru the WC dashboard. Any help would be appreciated as this has tanked my entire automation. @ady624


I have no clue but lots of thoughts that may or may not have any effect…

  • reboot your ST hub
  • clean up and rebuild your data cache in webcore
  • login to IDE and check that your time zone and sunrise/sunset are correct
  • post an image of a piston with trace enabled and post logs
  • what shard are you on?


So I went hardcore here and ran a back up of the pistons. Deleted my Webcore instance and started a new one. Tested a new piston with no issues. Started importing the backup pistons and they seem to work fine. So Disaster avoided with minimal work to restore.