Unable to edit or add any pistons


1) Give a description of the problem
I can’t add or edit any pistons - when I try to do so, I get the waiting/loading logo but nothing ever happens. I have tried to go into the smart app and clean up and rebuild the cache, but that also fails.

2) What is the expected behavior?
To be able to edit the piston or add a new one

3) What is happening/not happening?
The edit screen won’t load, it just hangs on loading

4) Post a Green Snapshot of the pistonimage
I can’t get a screenshot because it won’t load

5) Attach any logs (From ST IDE and by turning logging level to Full)


Did you recently update the webcore smartapps in IDE? if yes, did you publish all of them when you updated? :slight_smile:


No I did not


I just added a log from ST - please let me know how I can fix this.


Any help here? I just got started with webcore this week and I’m itching to get back in there to make edits to my pistons.


Any error messages in IDE live logging when you try to edit or add?


Can you post a screenshot of the 4 SmartApps you installed in IDE?


I’m not sure but I posted the live log from when I tried to edit a piston - is that what you’re looking for I hope? I don’t know the logs well enough to be able to tell if there is an error in there.


Ah, I totally skipped that part sorry. I tried to view it but not able to at the moment. Must be some filters here at work. You can just copy and paste the relevant parts here if you can.


Does this help? Sorry I’m at work and on my phone - I can send a screenshot from my laptop tonight if that’s what you need.


I can take another look but when I looked at it originally, I couldn’t decipher much of anything going on so I wouldn’t be sure what is or is not relevant. Sorry I can’t be more helpful here…


The important part is to open Live Logging, clear it right before you try and add/edit a piston to try and catch anything (if anything) comes up.


When was the last time you updated the WebCORE SmartApps in IDE? Just wondering what version you have


I just installed it last week so it can’t be very old


The smart apps shown in your image should be black. It could mean nothing though… possible there is blank spaces added to your code :slight_smile:


I still haven’t been able to get this to work but I got a new phone on Friday and I am able to edit and access the pistons from there. I still can’t from my old phone or my laptop though. Any ideas here?