Unable to load Dashboard - invalid token error


New user here and I’m having problems accessing the webcore dashboard. I get the error “there was a problem loading your devices. The data shown below may be outdated. Please log out if the problem persists”
In ST IDE, I get the error: Dashboard: Authentication failed due to an invalid token

I saw similar topics here, here’s what I tried to debug so far:

1- uninstall completely webCore
2- reinstall (from github one time and from code another)
3- Changed webcore password
4- Clean up and rebuild data cache
5- remove all devices and readd
6- clean browser cache
7- Tried different browser (IE, Edge, Chrome and Safari)

Now, I don’t have error anymore when I log in the dashboard from Chrome but device status won’t update either.

Currently, I have only two devices in webcore, a virtual switch triggered from a Harmony Hub and a Tp-Link switch.

Switches state works ok in Smartthings but I can’t see it in webcore so I can’t create Pistons

Thanks for your help!!

There was a problem loading the dashboard data.... Unable to load webcore dashboard

Did you add the devices to webcore? Go to your instance of webCoRE in the ST app > settings > available devices > available devices > select devices by capability > group 1-3


Yes I added them. I can see them in the dashboard panel but they are always off, whatever the state in ST


I think I am confused. Are you referring to the side screen when creating/editing a piston? Because the developers removed the status last summer and now you will only see the list of devices available. Or are you talking about something else? Can you show a screenshot if it is something else.


I’m sorry if I’m unclear.
What I am referring to is this:

TV status is a virtual switch triggered by a harmony routine and test is a Tp-Link power outlet.

I can’t see the status change in the dashboard but you seem to indicate that this is a normal behavior.

Is this what you are referring to?


Ahh that dashboard. That is why I was confused, I was thinking of the main page which is referred to as a dashboard also.

The one you posted an image for was never completed so it basically does not work. I heard once they only completed about 5% of the coding on that page but that has been about 3 years ago so I doubt it will ever be finished.


Oh it’s good to know! Thanks!!

I created a simple piston to confirm that everything is working (if tv status changes to on, switch power outlet on) and it is working!

Thanks a lot for your help, I think I’ll have more questions in a near future! :smiley: