webCoRE dashboard not updating


I am trying to update to the v0.3.10a.20190223 version of webcore to use the new $twcweather API, but it is not working. Webcore dashboard in top left corner still shows " Home \ webCoRE (v0.3.109)", and my pistons aren’t able to use $twcweather. So far I have tried the following:

  1. Updating webcore to the latest version using the IDE and github pull.
  2. Update the webcore, webcore dashboard, webcore piston, and webcore storage manually with code copy and paste, but that hasnt helped either. Both 1 and 2 result in the version of all of these being v0.3.10a.20190223, but this is still not reported on the webcore dash board, and the $twcweather API is not available.
  3. Deleting webcore, , webcore dashboard, webcore piston, webcore storage, from the IDE, and doing a completely new pull, still isnt working. I always make sure to publish and pull webcore first, then publish and pull the others.
  4. Un linking my connection to github AND doing step 3, still not working. Including this and restarting my browers, clearing all cookies, cache (and even tried another browser), still no luck.
  5. I have also checked on the IDE My Locations>smartapps, and there is only 1 version of webcore installed. I do notice a separate webcore and webcore(dashboard) indented below it, but I believe that is expected.

One thing that is weird is the dashboard shows Home \ webCoRE (v0.3.109), but when i modify my pistons it shows the correct 3.10a version, buuut, still no access to $twcweather. I am also still getting the notification on the main screen of the dashboard to update. I feel like I am taking crazy pills. :slight_smile:

Can anyone help?


It might be as simple as doing a hard refresh on your Dashboard.


Hi WCore, Thanks for the response. I just tried this, but unfortunately it did not work. :frowning:


I had this problem when first trying to update and shutting down my browser and restarting seems to get a good reload with the new webcore. Shouldn’t be much different than the hard refresh but that is what worked for me.